Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently upgraded to 12.04 LTS and I have an ATI Radeon HD5670. I've heard that the open source 'Radeon' driver is used by default. However, it wasn't showing anything for me. What I did was I added the 'nomodeset' option to boot up and install fglrx. But it didn't work well for me as it introduced a lot of problems (freezes/glitches). So I removed/purged fglrx and am planning to use the open source drivers instead.

So my question is this: Why is my default Radeon driver not working? Is anyone having a similar issue? I've also tried using the ubuntu-x-swat driver by running the ff commands:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update

But the result was the same as the Radeon driver. Nothing shows up on system boot. Any ideas? Thanks in advance!

Update Running lspci -nn | grep VGA gives me the following:

02:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Redwood [Radeon HD 5670] [1002:68d8]
share|improve this question
    
But I don't want to use fglrx, I want the open source drivers. From what I understand, Ubuntu 12.04 LTS uses the 'Radeon' driver (open source driver) by default. Please correct me if I'm wrong. –  mumble Aug 4 '12 at 17:10
    
Please edit your question and add the contents of lspci -nn | grep VGA –  Bruno Pereira Aug 4 '12 at 19:17
add comment

2 Answers

up vote 1 down vote accepted
  1. Go to terminal past sudo ppa-purge ppa:ubuntu-x-swat/x-updates
  2. sudo apt-get update
  3. sudo add-apt-repository ppa:ubuntu-x-swat/x-update
  4. sudo apt-get update && sudo apt-get upgrade
  5. lshw -c video

If you want more information about the loaded driver, run modinfo or glxinfo

share|improve this answer
    
I followed the steps after repairing the packages and running fsck in recovery mode and now it works! thanks! –  mumble Aug 4 '12 at 19:29
    
It doesn't work. –  Adam Sack Mar 2 '13 at 20:38
add comment

https://help.ubuntu.com/community/BinaryDriverHowto/ATI

Installation

NOTE: If you are switching from another OEM's hardware, NVIDIA for instance, you must uninstall the driver for that hardware before installing the AMD/ATI driver.

Using the Ubuntu repositories (recommended)

The easiest way to install binary drivers is to use the built in Hardware Drivers manager in Ubuntu.

In Ubuntu 10.10, this is found under System -> Administration -> Additional Drivers.

After the fglrx driver is installed, reboot your system and login. To check whether the fglrx driver is working, open a terminal and type:

fglrxinfo

If fglrx is installed and working well you should see an output similar to:

fglrxinfo display: :0 screen: 0 OpenGL vendor string: Advanced Micro Devices, Inc. OpenGL renderer string: ATI Radeon HD 4300/4500 Series
OpenGL version string: 3.3.11399 Compatibility Profile Context

Using the Ubuntu repositories (alternate command line method, including hardware acceleration)

For users who find that the Additional Drivers method does not work correctly, the driver may also be installed from the Ubuntu repositories using the terminal. Hardware acceleration can also be activated, which some users may find helpful. The hardware acceleration piece has been tested on Ubuntu 12.04 Precise Pangolin.

(Note: this method will not work for these legacy cards and the legacy driver for them will not work with xserver. If you have one of these cards, you will have to use the default open source driver or purchase a different card. Unfortunately, this list is not exhaustive and some cards included in this list may also refer to products sold under different model names.)

(Note: If your machine has hybrid Intel/AMD switchable graphics, please consult the Ubuntu Forums thread here first. At the time of writing, the method described below MAY NOT WORK for Intel/AMD switchable graphics. If you have an Intel/ATI hybrid, it is advisable to wait until further instructions are available.)

  1. Save backup copy of xorg.conf in case this doesn't work.

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.BAK

  1. Remove/purge current fglrx and fglrx-amdcccle (If you have used a method outside of aptitude, apt, Software Center or Synaptic, follow the other party's instructions for removal.)

sudo apt-get remove --purge fglrx fglrx-amdcccle

For some users, the fglrx-updates and fglrx-amdcccle-updates packages do not work. If you attempted to install them, also do

sudo apt-get remove --purge fglrx-updates fglrx-amdcccle-updates

  1. Reboot

  2. Install the driver.

sudo apt-get install fglrx fglrx-amdcccle

  1. Generate a fresh xorg.conf BEFORE REBOOTING!

sudo aticonfig --initial

If you are using multiple AMD/ATI graphics cards, use

sudo aticonfig --adapter=all --initial

  1. Reboot again.

  2. Use the Catalyst Control Center to make final adjustments to your monitor setup.

If, after rebooting, you are presented with the message "Could not apply the stored configuration for monitors", do not be alarmed. It simply means that you will have to use the Catalyst Control Center to configure your monitors as you should even in the case where this warning is not shown. This most likely to happen with multiple monitor applications (particularly if the monitors are of different sizes) and multiple graphics card applications.

If you cannot get the Catalyst Control Center to launch from an icon, try from the terminal:

gksudo amdcccle

  1. To get hardware acceleration (tested on 12.04 Precise Pangolin), you need to add four more packages.

sudo apt-get install xvba-va-driver libva-glx1 libva-egl1 vainfo

You can test to see if you have installed them correctly thus:

sudo vainfo

When installed correctly, you should get the following:

libva: VA-API version 0.32.0 Xlib: extension "XFree86-DRI" missing on display ":0". libva: va_getDriverName() returns 0 libva: Trying to open /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so libva: va_openDriver() returns 0 vainfo: VA-API version: 0.32 (libva 1.0.15) vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.8 vainfo: Supported profile and entrypoints VAProfileH264High : VAEntrypointVLD VAProfileVC1Advanced : VAEntrypointVLD

share|improve this answer
    
Hi, I ran the ppa-purge command again and reinstalled the ubuntu-x-swat driver(the 5 steps), and it booted successfully! I'm not sure if it was a simple mistake of mine or due to repairing the packages or running fsck before reinstalling that fixed the issue. Thanks a lot! –  mumble Aug 4 '12 at 19:24
    
so you got it work now?!? if you did can i get some rep points –  Snafu006 Aug 4 '12 at 19:26
    
Yup, sure. thanks again :) –  mumble Aug 4 '12 at 19:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.