Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu One to synchronize a directory which I use to create and compile latex files. But, always, when a new file is generated, the files, instead of having the file-type extension like file1.pdf, they gain an extra suffix like file1.pdf.u1conflict, file1.pdf.u1conflict.1 so on. And many such files are generated when I compile pdflatex documents. Ultimately it lead to an error, saying that a file is not found while compiling. And the actual reason is, that file has got a new extension, which is, .u1conflict.

share|improve this question
add comment

5 Answers 5

up vote 1 down vote accepted

*.u1conflict files represent the case when you've modified a file on two computers and then tried to synchronise. In general, you'd either want to pick which version to keep, or try to merge the changes in the two versions. Usually you wouldn't want to upload the conflict to U1, but if you do you can rename the .u1conflict version.

.u1partial files represent partially downloaded files. If you have one of these hanging around, it might indicate that the synchronisation daemon died while downloading the file. As before, you probably don't want one of these uploaded to your U1 share.

As far as other restrictions go, U1 stores filenames as unicode strings. So if you have filenames that are not valid UTF-8 it may have troubles. This shouldn't be much of a problem on Ubuntu systems since it uses UTF-8 locales.

Taken from: https://answers.launchpad.net/ubuntuone-client/+question/78943

Hope this helps.

share|improve this answer
    
Your last point seams to be a plausible reason. In the beginning I had used only Gedit for editing those files, and I didn't have any problems. Later I started to open those files frequently on notepad++ from a windows PC. The notepad++ shows the encoding as ANSI. After I started using notepad++ some files failed to open on gedit (The error was character set couldn't be recognised). So the above mentioned issue cropped up later on. –  nixnotwin Dec 15 '10 at 14:22
add comment

hmm... while I can see why this has happened, it shouldn't. Could you please enable debug, restart syncdaemon, wait for it to be idle, reproduce the issue, file a bug, and upload a tarball of ~/.cache/ubuntuone/log/? If you consider your filenames to be sensitive or private, mark the bug private before uploading.

share|improve this answer
add comment

In your specific situation, it's a problem of saving before the first file has had a chance to sync. I've had this problem with my novel as well. The solution, is to disable u1 while working on the files, and enable it again when you are done saving the files.

share|improve this answer
add comment

I had the same problem with latex and i solve it manually. I deleted the conflicted archive at u1's site, then, i generated my pdf without conflicts.

share|improve this answer
    
In my case the files which had .u1conflict extension weren't there on ubuntu one site. Only on my local directory those files were there. –  nixnotwin Dec 15 '10 at 14:14
add comment

I've had this problem from time to time. Sometimes I can simply delete the conflicted file on the u1 website, and rename the local file without the .u1conflict extension and it will work.

Today, however, I ran into this and I had to take a couple extra steps:

  1. Delete conflicted file on one.ubuntu.com
  2. On local machine, stop u1 client by running u1sdtool --quit and then ps -ef | grep ubuntuone-client to make sure it's stopped.
  3. Move the conflicted client file to a folder that isn't managed by u1
  4. Start the u1 client again by running u1sdtool --start . If this step fails, you may have to stop the client (u1sdtool --quit) and try starting it again.
  5. Connect the u1 client by running u1sdtool --connect
  6. Run u1sdtool --status a few times and wait until is_online is True
  7. Lastly, put the conflicted file back in the u1 managed folder on the local machine (minus the .u1conflict extension) and wait for it to sync.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.