Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got 4GB on my machine (two cards of 2GB) although the command free -m says:

total: 2001  
used: 1816  
free: 185 

I've got 12.04 and I think PAE should be installed and enabled automatically.

Why is that?

share|improve this question
2  
Do the RAM sticks sit properly in the slots? Have you tried testing each stick by itself? –  mikewhatever Aug 4 '12 at 10:43
1  
I had a similar issue and got only 1GB of RAM when I had 4GB installed, the solution for me was to boot into BIOS and then just save the current settings again. (In BIOS it said 4096 MB RAM.) After that it worked as normal. –  Alvar Aug 4 '12 at 11:01

4 Answers 4

up vote 3 down vote accepted

Two things may be happening:

1 - Either you have installed the 32 bit version of Ubuntu (i386) which is unable to "see" 4 gigs of RAM or more (Actually, 32 bit oses usually see about 3,5 gigs of RAM, including Ubuntu, unless you have installed and enabled the PAE - Physical Address Extension enabled kernel, in which case it can see all 4gb, all the way up to 64gb, at least in theory. For information on how to enable the PAE kernel please see:Enabling PAE). If you would like native support of your 4gb, and/or planning to add more in the future, you are better off installing the 64 bit edition of the Ubuntu 12.04 (should be under a name x86_64, or x64, or amd64). If you decide to do so, do not forget to backup the files that are important to you before doing so.

2 - Make sure that the dimms are installed properly. What may also have happened is that one of the two dimms may probably be problematic, in which case, to determine which one of the two is problematic, remove each one of the two and see if the system responds properly to the change. If none of them appears to be problematic, go to solution #1.

share|improve this answer

It looks like your machine is only detecting 2GB of ram.

First open a terminal, then run the following command and edit your answer to include the output.

  sudo lshw -c memory

Has the additional ram been installed recently, and can you confirm it has worked previously?

You may simply need to remove and re-install the ram making sure it sits properly in the slot..

share|improve this answer

Take the RAM out of the slot, and put it back in again after cleaning.

share|improve this answer
    
I think it might be it! –  socksocket Aug 4 '12 at 11:32

pull the power cord first the push the power button to drain the system caps of charge wait 5min then pull them and use a ground stap for wrist or keep idle hand touching metal, to prevent ESD damage.

A+ cert.

share|improve this answer
    
Welcome to AskUbuntu. Are you suggesting then resetting them, replacing them? If you intend to add this to a "previous" answer please know that the order of the presentation of answers changes, so it's better for each answer to stand on its own. –  John S Gruber Aug 21 '12 at 2:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.