Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to run MyUnity, and it's been working fine until today, when it comes up with the message:

So, apparently I am running Unity-2D. So I did a little command-line search withecho $DESKTOP_SESSION and sure enough, it spat out simply "ubuntu-2d".

I have been using Ubuntu Tweak and perhaps I did something stupid in there, but I don't think it even had a feature like that. I've also noticed the clear differences in Ubuntu 2D to Ubuntu 3D, as well.

I have 12.04 Ubuntu. So is it possible for me to "revert" back to Ubuntu/Unity 3D?

Edit: My graphic card is a 2GB dedicated AMD Radeon HD 7750, which I've come to think needs to be upgraded 12.6 version. I'll try this and let you know the of the outcome, thanks so much for helping.

Result: after successfully updating the graphics card, I now can run 3D. Thanks so much to all of you and I'm sorry for such an unusual question!

share|improve this question
1  
do you have autologin enabled? If yes, logout and login to the unity 3d session by clicking small ubuntu logo in the login field and selecting 'Ubuntu' session –  Anwar Shah Aug 4 '12 at 9:51
    
Unity3d is usually the default option, and 2d is only selected unless if the hardware has problems with the 3d version. What graphics card is there? –  mikewhatever Aug 4 '12 at 10:23

2 Answers 2

up vote 6 down vote accepted

You can determine if you are running Unity 3D or 2D by open the system monitor. If you see a process named compiz in the processes tab, you are using Unity 3D. If it's running metacity instead, you're working with Unity 2D.

Ideas to get Unity 3D working:

  1. First, install the package nux-tools and run /usr/lib/nux/unity_support_test -p in a terminal window. It will show if your hardware is supported by Unity 3D. If you have an Nvidia or AMD/ATI graphics card, you might have to install the proprietary drivers first to get (good) 3D support. If it says Unity 3D supported: yes, you can continue with the other steps. If not, you cannot use Unity 3D.
  2. Install Unity if it's not installed by running sudo apt-get install unity gnome-session.
  3. Now log out, there should be an Ubuntu logo next to your username in the login manager. Click on it and select "Ubuntu", and log in again. Unity 3D should start.
  4. If it's still starting Unity 2D and not 3D, open a terminal and type unity --replace. Unity 3D should start, if not, the terminal output might be interesting.
  5. If all above doesn't work, create a new user and log in. Don't forget to select "Ubuntu" as in 3. Maybe some of your old user's preferences are broken, a new user will start with fresh preferences.
share|improve this answer
    
Thanks so much for your answer, I've come to think I need to update my graphics card - which I will now mention in the question description - before I can run Unity, which seems a little odd, considering I got this computer last week! –  Mochan Aug 5 '12 at 3:13
    
AMD/ATI is a problematic choice for graphics on Linux. Ubuntu ships with a free driver named "radeon", which is developed by the community and does not support 3D well on newer chipsets like yours. The proprietary driver from AMD is quite buggy and not always up-to-date. Intel on the other side develops open source and high quality drivers. They also release their drivers months before the hardware release so the hardware works out-of-the-box on latest distributions. If you need more power, choose Nvidia. The driver is proprietary, but has the same quality as the Windows driver. –  user244 Aug 6 '12 at 9:09
    
My card is the AMD Radeon, like you mentioned. I don't know whether this relates to what you're saying. –  Mochan Aug 11 '12 at 11:17
    
If I unterstood correctly, you've updated your graphics driver (Catalyst/fglrx) to the latest version (you haven't replaced your old graphic card with a new one you bought), so the problem was caused by the driver not supporting 3D on your hardware. –  user244 Aug 12 '12 at 14:52
    
Yes, the fglrx. And yes, it was. So I suppose the name of the card is completely irrelevant to the driver name? Gosh, sorry I'm a noob hahaha –  Mochan Aug 26 '12 at 12:33

I suggest you to have a look at the 2 answers of that question
You will learn out to configure the file /etc/lightdm/lightdm.conf

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.