Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to setup my 3D graphics card.

$ lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI RV770 [Radeon HD 4850] [1002:9442]

According to the Radeon Driver open source driver page, my card is very well supported. I followed the instructions to set it up (very simple now that there is not a lot of mucking about in xorg.conf).

I checked to see the driver was installed properly:

$ dmesg | grep drm
[    3.542014] [drm] Initialized drm 1.1.0 20060810
[    3.613929] [drm] radeon defaulting to kernel modesetting.
[    3.613933] [drm] radeon kernel modesetting enabled.
[    3.627683] [drm] initializing kernel modesetting (RV770 0x1002:0x9442 0x1043:0x024E)

I also installed mesa-utils so I could make sure OpenGL was working properly with my card. Here is the relevant info from that (please let me know if you need something else to answer my question):

$ glxinfo | grep rend
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
    GL_NV_conditional_render, GL_AMD_draw_buffers_blend,

(Note: I have dual monitors, but, at this point, they are showing the same image as I have not yet set that up.)

However, when I install phoronix-test-suite and run lightsmark, I only get 1FPS and everything completely freezes during the soft shadow test. I'm not very experienced with graphics/graphics cards, etc, and was wondering if anybody could point me in the right direction.

If I put additional output (VERBOSE) for glxinfo, I get this...don't know if this helps debug at all.

$ LIBGL_DEBUG=verbose glxinfo
name of display: :0
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/
libGL error: failed to open drm device: Permission denied
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /home/jason/.drirc: No such file or directory.
share|improve this question
up vote 4 down vote accepted

Took me a bit, but I figured out what was going on. Steps to resolve...

sudo chmod 666 /dev/dri/card0

That solved the permission issue.

sudo apt-get install driconf

This solved the driconf warnings that I was receiving.

And, just for good measure...dual monitors...

xrandr --output DVI-0 --left-of DVI-1
xrandr --output DVI-1 --right-of DVI-0
share|improve this answer
Adding yourself to the video group (using sudo gpasswd -a $USER video) followed by a re-login should give he same (persistent) effect as sudo chmod 666 ... in this case. – Lekensteyn Aug 4 '12 at 16:14
@Lekensteyn - Ah...forgot to mention that. I did add myself to the video group. Didn't realize I had to relog, though, for that to work. I'll give that a shot. (I like that better than having to change internal permissions on my devices.) Thanks! – JasCav Aug 4 '12 at 16:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.