Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Komparator4 v0.8 from the terminal of Ubuntu 11.10. I entered this command and work fine:

mkdir build && cd build && cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` ..

But when I enter make I get this output whit error messages.

I installed this program with this method twice previously and I had no problems.

What I'm doing wrong?

share|improve this question
    
The code is written perfectly. Each char is necessary. –  Lucio Aug 4 '12 at 20:39
    
Which OS (Kubuntu?), version (11.10?) and Komparator4 version (0.8 is available...) –  izx Aug 18 '12 at 4:25
    
Have you reviewed the issues/comments in askubuntu.com/questions/160222/… ? Are you missing any of the required packages? –  david6 Aug 18 '12 at 5:47
    
@david6 Yes, I reviewed that question and I installed all the packages without problem. After that I installed the app without problems but this time is different. –  Lucio Aug 18 '12 at 20:56

1 Answer 1

up vote 3 down vote accepted
+50

The errors you get, e.g.:

index.docbook:1054: parser error : Entity 'install.compile.documentation' not defined

is the exact behavior displayed by an old serious bug in Komparator, which was fixed in late 2011 in Komparator 0.6.

If you are still getting this error, you should report it as a bug to the Komparator dev-team.

Temporary Alternative: build without documentation

For now, if you wish to build the package and can just refer to the online documentation, here's how:

  • In the top level folder, edit CMakelists.txt and in front of line 38, add_subdirectory(doc), add a #, i.e. #add_subdirectory(doc).
  • Save, exit, and cd build && cmake .....
  • This should build the package successfully.

I was able to successfully build Komparator 4 0.7 and Komparator 4 0.8 on an up-to-date Kubuntu 11.10.

share|improve this answer
    
I updated my question with my OS and version of K. I also build Komparator4 v0.7 without problems but a couple of days later I uninstalled it and when I tried again (with the same version) this errors appear. –  Lucio Aug 18 '12 at 21:04
    
Added comment to 62483 –  david6 Aug 18 '12 at 23:51
    
I updated the system, I downloaded and builded Komparator but nothing happens. I still get the same output with errors. –  Lucio Aug 19 '12 at 22:54
1  
@Lucio: please see edited answer - I found an old bug in Komparator exactly similar to your problem, but they say it was fixed. I have added an alternative method to successfully build the package. –  izx Aug 21 '12 at 20:17
    
@izx I don't know how you do, but you do. It works. Thanks for your time! –  Lucio Aug 22 '12 at 2:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.