Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This branch here is supposed to be importing code from the following Git repository:

http://git.chromium.org/webm/libwebp.git

However, it isn't. According to "Recent revisions" further down the page, the latest commit was May 14 of this year. This does not correspond with the actual revision history of the Git repository (the latest commit was 11 days ago).

Here is the output from the latest import (20 minutes ago).

What is going on? There aren't any errors - just nothing getting imported.

share|improve this question
1  
I'd try asking this on Launchpad itself. LP devs actually read the questions, and they can dig into the problem deeper. –  andrewsomething Aug 4 '12 at 0:03
    
The Launchpad branch page, before the list of logs: Last successful import was on 2012-05-15. So Launchpad recognizes that the git branch is not being imported. When, on my 12.04 system, I tried ` bzr git-import git.chromium.org/webm/libwebp.git` it worked with the latest revision on 7/23/2012. –  John S Gruber Aug 4 '12 at 4:24
    
I think andrewsomething has a good idea. Looks to me like a problem the launchpad administrators would have to fix. –  John S Gruber Aug 12 '12 at 2:01
add comment

2 Answers 2

up vote 1 down vote accepted

This looks like a bug in the Git importer on Launchpad (which is basically bzr-git, http://launchpad.net/bzr-git). I've seen this issue before when fetching branches over HTTP.

It might be worth filing a bug in launchpad about this (https://bugs.launchpad.net/launchpad/+filebug) if there isn't one already.

share|improve this answer
add comment

The Launchpad wiki page https://help.launchpad.net/VcsImports gives some advice on dealing with importing issues. Combining that with Jelmer's answer I would recommend to try in the following order:

  1. ask around on #launchpad on Freenode
  2. file a bug on https://bugs.launchpad.net/launchpad/+filebug
  3. mail the Launchpad team at feedback@launchpad.net

Based on your branch's page in Launchpad and a git clone of the Git repository it's quite clear that there is a problem.

I'm curious what will happen if you perform the import locally on your PC and push your local branch to Launchpad. Will that bring Launchpad back to a sane state so that it can continue importing new revisions that will be added later in the Git repository? Or what if you delete and import again?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.