Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got my friend's laptop to install ubuntu 10.10. It already had windows 7. Wifi adapter was On but it didn't show ANY WiFi Network in windows. After Installing Ubuntu, it shows Wireless Disabled. The lshw command too shows network is disabled. I am using Lan now.

The device is Intel Wifi Link 5100. The proprietary hardware driver option shows that no 3rd party driver needed.

I ran the rfkill list all command and it ALWAYS shows that HardBlock Yes (turned On) and I could not change to Hardblock No. And I tried many solutions available regarding this issue.

But when I boot the laptop with a Pen drive with Ubuntu 10.04, the wireless works just out of the box, without any extra driver or any configuration. It just works!

What could be the problem? Wireless not working in both the Windows and Ubuntu installed in the laptop but works just out of the box, when an Ubuntu on Pen Drive is used.


Some more Observations

I ran 2 versions of Ubuntu using Pen Drive, on same laptop - 10.04 and 10.10.

10.10 behaves the same way, it says wireless is disabled by hardware switch but 10.04 just works out of the box. I am able to connect to my router just by providing the wireless passkey and a keyring password.

And When i restart my laptop after running 10.04 in pen drive, without shutting down, only restart, the wireless works in 10.10-laptop!

Butn again, when I completely shutdown and turn on, 10.10 in laptop doesn't work.

So this clearly shows its a bug in ubuntu level and nothing wrong with hardware. Also upgrading also is not working, as I tried upgrading to 11.04. It behaves the same way like 10.10

share|improve this question

closed as off-topic by Eric Carvalho, Alvar, AgentCool, Kevin Bowen, Alvin Row Aug 12 '13 at 17:17

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Ubuntu 10.10 has already reached End Of Life, so it's not really supported anymore. I suggest you try downloading a 12.04 installer and try with that. –  roadmr Aug 3 '12 at 21:06
    
Upgraded to 11.04. Facing the same issue! What is the surety that wireless will work in 12.04? –  tekvijay Aug 4 '12 at 12:19
    
11.04 is not the latest release use 12.04 not 11.04, not 11.10, not 10.10. –  Uri Herrera Aug 4 '12 at 17:27
add comment

Browse other questions tagged or ask your own question.