Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to run VirtualBox on Ubuntu, it used to work a while ago but I can't remember when or why. However when I double-click on an OS to run, it tries to start - opens a window for the virtual OS, gives the "host key" message, but then 5 seconds later closes the OS window and gives this error:


Result Code: 
NS_ERROR_FAILURE (0x80004005)
IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

If I run it with sudo virtualbox I still get the same problem. I've tried sudo apt-get purge virtualbox then sudo apt-get install virtualbox. I notice during the re-installation I get this amongst all the other output on the console:

Setting up virtualbox (4.1.12-dfsg-2ubuntu0.1) ...
 * Stopping VirtualBox kernel modules                                    [ OK ] 
 * Starting VirtualBox kernel modules
 * No suitable module for running kernel found                           [fail]

Any ideas?

share|improve this question
If I delete /home/duncan/.virtualbox and /home/duncan/VirtualBox VMs and start from scratch the error still occurs. However I remember VirtualBox working at one point so any other ways to reset settings may help. – stackunderflow Aug 3 '12 at 20:52
just type this in terminal, sudo apt-get install virtualbox-dkms , if already exist reinstall and you ready to go. – Shaharil Ahmad Sep 5 '13 at 13:53

11 Answers 11

Solved the problem on my Ubuntu 12.04 install

sudo apt-get purge virtualbox
sudo apt-get install build-essential linux-headers-`uname -r`
sudo dpkg -i ~/download_folder/virtualbox-4.2_4.2.12-84980~Ubuntu~precise_i386.deb

You can get the .deb files here

This pretty much did it for me!

share|improve this answer

I had the very same problem and it helped to install linux-headers for current kernel and reinstalled virtualbox-dkms and dkms.

share|improve this answer

Had the same/similar issue:

 * Starting VirtualBox kernel modules
 * No suitable module for running kernel found                           [fail]

Seems like my issue was with the building of the kernel. Solved by using dkms for dynamic building:

sudo apt-get purge virtualbox
sudo apt-get install dkms build-essential linux-headers-`uname -r` linux-source
sudo apt-get install virtualbox-dkms 

Verified with:

sudo service virtualbox status 
sudo service virtualbox restart
share|improve this answer
Shouldn't it be build-essential and not build-essentials? – Reut Sharabani Oct 31 '15 at 16:56
@ReutSharabani correct, 'build-essentials' updated to 'build-essential' – kidmose Nov 5 '15 at 18:56

It seems to be a problem of permission. Try:

sudo chown root:root /usr
sudo chown root:root /usr/lib
sudo chown root:root /usr/lib/virtualbox

You can have a look at this ticket for more information.

share|improve this answer

In my case ubuntu 12.10 64! I downloaded virtualbox-4.2_4.2.6-82870~Ubuntu~quantal_amd64

sudo apt-get purge virtualbox-4.2  
sudo apt-get purge virtualbox-guest-additions-iso  

sudo apt-get install linux-headers-3.5.0-21-generic  
sudo dpkg -i virtualbox-4.2_4.2.6-82870~Ubuntu~quantal_amd64.deb  
share|improve this answer
This doesn't fix the issue at all... It's just another way of getting the same error messages. – weberc2 Feb 2 '13 at 21:27

In my case I use

sudo apt-get purge virtualbox

before reinstalling it.

share|improve this answer

Installed VirtualBox packages from Ubuntu 12.10 repositories. Did NOT purge Virtualbox packages nor downloaded or installed foreign debs.

Installed dkms, linux-source and linux-headers-3.5.0-23

(uname -r output was 3.5.0-23-generic)

Restarted VirtualBox.

Everything worked fine

share|improve this answer

For me just using apt-get was enough:

sudo apt-get install virtualbox
share|improve this answer

Sounds like your vboxnetflt module is not loaded. Run this:

sudo modprobe vboxnetflt
share|improve this answer
up vote 0 down vote accepted

Resolved here. Have some serious permission problems and need to do a clean install.

Edit: quote

That listing of your /usr directory raises all sorts of red flags with the "2000 513" values for owner and group. Appearance of the numbers instead of user/group names indicates that the user and group do not exist in your system. Additionally, "2000" is a most unlikely user id for any flavor of Ubuntu. Non-system UIDs and GIDs start at 1000 and go up from there one at a time; to reach 2000 you would have to have added a thousand additional users! Similarly, system UID/GID numbering starts at 0 (which is "root") and seldom goes as high as 200.

Does your system have any other users? If so, is it likely that one of them could have been doing unusual things without your knowledge?

When any of my systems show such unlikely happenings, my first thought is to back up all critical data, then nuke the box and reinstall everything from scratch. While all flavors of Linux are much less vulnerable than some more widely used systems, mischief is always a possibility -- and gremlins can cause corruption of files without any human mischief being involved. You describe the system as "valuable" so a good backup needs to be available at all times anyway, before you make any attempt to fix things.

share|improve this answer
Please provide the content in your link for others to see easily and so the information is preserved should the linked content be moved/deleted. – weberc2 Feb 2 '13 at 21:20

/etc/init.d/virtualbox start is trying to find a module vboxdrv for your current kernel... (/lib/modules/`uname -r` -name "vboxdrv.*). Please install linux-headers and try start again...

share|improve this answer
Does it help to refer to… ? – John S Gruber Aug 4 '12 at 3:41
That command is incorrect, and installing linux-headers doesn't have any impact on the issue. – weberc2 Feb 2 '13 at 21:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.