Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

complex issue. i bought my Mom a new desktop pc, with specs listed below (using HardInfo 0.5.1):

  • Processor : 4x Intel(R) Core(TM) i5-3450 CPU @ 3.10GHz
  • Memory : 3943MB (1228MB used)
  • Operating System : Ubuntu 12.04 LTS -Resolution : 1024x768 pixels -OpenGL Renderer : Mesa DRI Intel(R) Ivybridge Desktop
  • X11 Vendor : The X.Org Foundation
  • Genius Multimedia Keyboard
  • ImPS/2 Generic Wheel Mouse
  • Venus USB2.0 Camera

Two screens are connected - a 19" monitor through DVI, and a 26" HDTV through HDMI.

Displays Menu with TV

Ubuntu Displays shows that I can mirror displays with 1024x768 & 1440x900.

low res high res

Obviously I wanted the latter. Yet it doesn't work. 1024x768 does work, with no issues at all, but when i try to set the 1440x900 - the screens flicker, it take quite a while - and eventually doesn't work, as you can see here:

error 1 error 2

no only that - i must restart the computer since it becomes super slow, until i get a kernel panic. I sent the computer to the lab, and they claimed everything is ok with the hardware. They installed Windows 7 and showed me everything is fine, as seen here:

Windows 7 Display Menu

share|improve this question
    
That graphic card is the only one you have? Don't you have another like Nvidia or ATI? –  LnxSlck Aug 16 '12 at 12:54
    
What's the point? Installing proprietary drivers that are even worse? –  LiveWireBT Aug 17 '12 at 3:39
    
Yes - only an Intel card. No Nvidia on the board at all –  ushabtay Aug 19 '12 at 9:36

2 Answers 2

I have the same issue, and I still can not solve it, or can find anything helpful on how to fix. While reading online about it, I discovered that this is a bug. The problem arises when you try to do a multi-monitor setup with one monitor in a DVI port, and another in a HDMI. My suggestion is, do you have a VGA or DVI port on the HDTV. You could connect your HDTV with a VGA or DVI(DVI if you have two ports for it on your graphics card). This might work.

Also, does this graphics card have a Nvidia Chip on it. If so, you might have The Nvida X Server Settings application on your computer. From there, you can enable Xinerama and also Twinview. There might even be an option there to mirror.

I would give this issue some time, because eventually, it will be fixed, or a solution will be found.

I hope this can help you.

share|improve this answer
    
Thanks. The PC is with an Intel card, and connecting the HDTV through DVI is a mess - since it's quite far away (i bought an expensively long HDMI capable to connect the two together..) –  ushabtay Aug 19 '12 at 9:35
    
Bug #1039925 reported. bugs.launchpad.net/ubuntu/+source/linux/+bug/1039925 –  ushabtay Aug 22 '12 at 7:37

Sorry I cannot check but for XFCE and LXDE I use next script:

     #/bin/bash
     xrandr   --newmode   "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083          1088 1120 -hsync +vsync
     xrandr --addmode HDMI1 "1920x1080_60.00"
     xrandr --output  HDMI1 --mode "1920x1080_60.00"
     xrandr --auto --output HDMI1 --left-of VGA1

Via xrandr you can find your monitors and resolutions mode and configure Display positions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.