Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just recovered from a white screen of death I was having by reinstalling my nvidia drivers via the command line in recovery mode. When I rebooted after that, everything was fine, except one of my monitors is not displaying anything.

I ran sudo nvidia xconfig, which created the conf file for me, but the issue was not resolved. In X Server Settings, the secondary monitor (the one not displaying), is detected and enabled in TwinView, but its resolution is not detected and the screen is black. If I try switching workspaces, the little window showing all workspaces show the second monitor sitting next to my monitor, same as in X Server Settings.

What options do I have for resolving this?

Thanks a lot!

Edit: My xorg conf has the following:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 302.17  ([email protected])  Tue Jun 12 17:05:44 PDT 2012

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 302.17  (buildd@rhenium)  Sun Jun 17 23:26:33 UTC 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Ancor Communications Inc VE248"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 570"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-3"
    Option         "metamodes" "DFP-3: nvidia-auto-select +0+0, DFP-0: nvidia-auto-select +1920+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this question

2 Answers 2

why dont you try reseting the display variable ; this may help you

its good to check Xorg configuration by cat /etc/X11/xorg.conf

share|improve this answer
    
Thank you. I've edited my post with the contents of my Xorg config. Was the take-away from the forum post to try gksudo nvidia-settings If so, it did not work. If it's not, I'm not sure which advice to follow on there. –  Alex Aug 3 '12 at 15:13

After looking around, I found the enabling Xinerama in the Nvida-settings fixed things for me. it does however completely disable the "Display" function in settings...so I cannot remove the second task bar thing...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.