Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On GNOME the screen locks when I suspend, and I find that a bit annoying (no one else in the house uses ubuntu anyway haha). What can I do to stop this?

share|improve this question
add comment

8 Answers

up vote 11 down vote accepted
+150

For 11.10

What worked for me on Ubuntu 11.10 is to execute the following in a terminal:

gsettings set org.gnome.desktop.lockdown disable-lock-screen 'true'

You can also install dconf-tools and use dconf-editor to set the same setting manually.

share|improve this answer
2  
this also disables the manual lock with ctrl+alt+L. Any ways to disable only the automatic lock? –  brillout.com Oct 25 '11 at 0:36
2  
In order to be able using the manual lock functionality after this fix, you can assign in System Settings -> Keyboard -> Shortcuts, Custom the Ctrl+Alt+L combination to this command: gdmflexiserver -xnest. Note: I've found the command here: ubuntuforums.org/showthread.php?t=1030073, I'm not sure if on my computer gdm coexists with lightdm, but for me it works. –  alexef Dec 8 '11 at 13:11
    
it appears that the command ships with lightdm (apt-file search /usr/lib/lightdm/lightdm/gdmflexiserver), so the suggestion is safe. Jorge, can you please update your answer? –  alexef Dec 8 '11 at 13:29
    
FYI, this also works for 12.04 (as of the beta at least). That is, both the answer and alexef's fix (except I had to use the command /usr/lib/lightdm/lightdm/gdmflexiserver -xnest rather than just gdmflexiserver -xnest since apparently I have gdm installed too). –  greggory.hz Mar 28 '12 at 2:02
add comment

On Lubuntu 13.10 :

Open "Preferences" Open "Xfce Power Manager" Open "? Extended" and untick The "Lock screen when going for suspend/hibernate" box.

share|improve this answer
add comment

For 13.04

Open a terminal (Ctrl+Alt+T) and type the following:

gsettings set org.gnome.desktop.screensaver ubuntu-lock-on-suspend 'false'
share|improve this answer
add comment

For 12.04

In the Top-right position of the panel, Click on the Settings Icon, Choose System Settings. Choose System Settings -> Brightness and Lock.

Disable the Lock by Clicking on the Toggle Switch Button. This will prevent Automatic lock when system suspends.

You can of course Lock it by Pressing Ctrl+Alt+L Key combination always.

share|improve this answer
add comment

For 11.04 and earlier:

Did you verify that the option in the screen-saver about LOCKING the PC is off. Go to System > Preferences > Screensaver

Verify that Lock Screen when Screensaver is active is turned off. Also verify that Activate Screensaver when computer is idle is off too.

Looking around i found that you can also edit several Power Management options via the gconf-editor.

Press ALT+F2 and type gconf-editor

Go to: Apps > Gnome-Power-Manager > Lock

Check the option use screensaver settings This way it checks for the option you put in the screensaver window.

There might be other options there that will help you like gnome_keyring_hibernate and gnome_keyring_suspend (If they use the keyring they might be the ones asking for the password when locked)

This are EXTREME cases please let me know if they work so i can copy them here and make a reference:

First do this: http://ubuntuforums.org/showpost.php?p=9509427&postcount=10

Then do this: http://ubuntuforums.org/showpost.php?p=9756347&postcount=11

share|improve this answer
    
I already have it off on both. It only does it on suspend. –  RolandiXor Dec 13 '10 at 1:13
add comment

For 11.04 and earlier:

If you disable the screen lock by setting /desktop/gnome/lockdown/disable_lock_screen, you will not need to unlock the screensaver when you resume from suspend.

gconftool -s /desktop/gnome/lockdown/disable_lock_screen -t bool true

This works for me on Ubuntu 10.04.

share|improve this answer
add comment

For 11.04 and earlier:

Run gconf-editor, then under /apps/gnome-power-manager/lock uncheck the suspend checkbox.

share|improve this answer
    
Been using this method for years, although I actually just tick the "Use Screensaver property" instead, then I can control it with the screensaver gui in system/preferences/screensaver. –  Scaine Jan 14 '11 at 21:39
add comment

For 11.04 and earlier:

  • Edit your acpi-support file by pressing Alt + F2 and pasting

    gksu gedit /etc/default/acpi-support

  • Find the line that says LOCK_SCREEN=true and comment it out to disable screen locking on resume.
    alt text

share|improve this answer
    
This has no effect on my laptop for some reason. I have to modify gconf-editor entries, as detailed by Jeffrey. –  Scaine Jan 14 '11 at 21:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.