Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am aware that similar questions have been posted, and believe me, I have tried a lot of the solutions, but nothing works for me. So I think my case might just be special and deserves a new post.

I'm using Thinkpad T420s, with NVIDIA NVS 4200M graphics card. I installed Ubuntu 12.04 as soon as it came out, but Suspend never worked properly. When I try to resume my computer after suspending it, I just get a lit but black screen. The only thing I'm able to do is to turn off the machine using power button.

At first I thought that's an Ubuntu issue, so I tried Mint instead. However, I was surprised that I met the same problem using Mint: the screen just remains black after being resumed from suspend!

I tried installing pm-utils as many suggested, but it didn't work. I tried installing laptop-mode-tools as many suggested, but it didn't work. I tried installing NVIDIA driver, but it didn't work (weird that I couldn't see any driver in "Additional Drivers" even though I installed the NVIDIA driver). So now I have no idea what to do and am here asking for help.

Thanks a lot for reading this! Any advice will be greatly appreciated.

share|improve this question

You might be having problems with your hard drive power managment. I have had A LOT of troubles with Ubuntu suspension/resuming, and also tried all of the things you mentioned. Another thing I tried was reconfiguring the hard drive's power managment.

You can try editing "/etc/laptop-mode/laptop-mode.conf" from this:

# Power management for HD (hdparm -B values)

To this:

# Power management for HD (hdparm -B values)

It might help. Good luck!

share|improve this answer
Thanks for help! Did that work for you? – Derek Chiang Aug 4 '12 at 4:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.