Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying compile mdk3-v6 but I run into errors.

Started off by trying sudo apt-get install that didn't work. Downloaded from another source and tried tar -xjf mdk3-v6.tar.bz2

Keep getting No such file directory error. Also downloaded all the 32bit support since I'm running 64bit & have the build essentials and all that. Tried using -xzf instead of -xjf and other tasks. Changed Makefile to -pthread. I think I've tried everything.

If someone could help me out I'd appreciate it.

share|improve this question
    
Possible duplicate? askubuntu.com/questions/82497/… (good compile link in the answer to that question) –  fossfreedom Aug 3 '12 at 9:14
add comment

1 Answer 1

It looks like you're in your home directory but your file probably downloaded in the Downloads directory or something similar.

You need to be in the same directory as the file or specify by doing tar xjf Downloads/blah.tar.bz2

A good trick I use instead of typing it all out is just type in the first few keys and hit Tab and the shell will autocomplete the filename for you. If you do that and the file doesn't complete, you know you're in the wrong directory.

share|improve this answer
    
I tried that and I got the same type of message. tar -xjf Downloads/mdk3-v6.tar.bz2 tar (child): Downloads/mdk3-v6.tar.bz2: Cannot open: No such file or directory tar (child): Error is not recoverable: exiting now tar: Child returned status 2 tar: Error is not recoverable: exiting now Could it be that I'm missing bzip2 somehow? –  Josec Aug 3 '12 at 23:14
    
You need to put where you actually saved the file as your path. –  Jorge Castro Aug 4 '12 at 0:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.