Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My problem is that the Bash shell stops showing the characters I type into it. It does read the commands though.

I've come across this problem quite a few times and I don't understand what causes it. I know how to solve it, but I really don't like it when I'm "voodooing" my way of out of problems.

I'll describe the two ways I've come across this problem:

I'm running a certain process, http://pythonpaste.org/script/ and sometimes when I stop that or it breaks control is given back to the shell. When I then go and type commands into the shell, the characters I type don't show up. When I press enter the commands are submitted. So for example:

  • I type "ls"
  • I only see an empty prompt and nothing more
  • I press enter and I'm given a listing of the files, in other words: the command is executed
  • when I give the "reset" command the shell starts working normally again

The second way this happens is when I give a command like this:

$ grep foo * -l | xargs vim

I use grep to find files that have a certain pattern and then I want to open all the files that result from the grep. This works like a charm (although not as fast as I'd hoped). But when I exit Vim my shell stops showing the characters I type into it. A reset command resolves the problem.

My guess is that both problems have an underlying reason, but I'm kind of stumped on how or what that reason is.

Searching for this problem is itself problematic because the description is kind of vague and has no hard search-terms for it.

Edit

Giving the

stty --all

command as per John S. Gruber's request gave the following output (whitespace edited for readability)

speed 0 baud;
rows 53;
columns 186;
line = 0;
intr = <undef>;
quit = <undef>;
erase = <undef>;
kill = <undef>; 
eof = <undef>;
eol = <undef>; 
eol2 = <undef>; 
swtch = <undef>; 
start = <undef>; 
stop = <undef>; 
susp = <undef>;
rprnt = <undef>; 
werase = <undef>; 
lnext = <undef>; 
flush = <undef>; 
min = 0; 
time = 0;
-parenb 
-parodd cs8 
-hupcl 
-cstopb cread 
-clocal 
-crtscts
-ignbrk 
-brkint 
-ignpar 
-parmrk 
-inpck 
-istrip 
-inlcr 
-igncr 
-icrnl 
-ixon 
-ixoff 
-iuclc 
-ixany 
-imaxbel 
-iutf8
-opost 
-olcuc 
-ocrnl 
-onlcr 
-onocr 
-onlret 
-ofill 
-ofdel nl0 cr0 tab0 bs0 vt0 ff0
-isig 
-icanon 
-iexten 
-echo 
-echoe 
-echok 
-echonl 
-noflsh 
-xcase 
-tostop 
-echoprt 
-echoctl 
-echoke
share|improve this question
1  
When this happens please enter stty --all and put the results in your question. Echo is a tty characteristic that is being turned off. Vim will do this while it is running, and it will put the terminal in raw mode, too. When it quits it should reset the terminal settings itself. When vim is running you don't want to echo the i command which puts the editor into insert mode, for example. These settings tell the tty device how it should be processing what you type. While vim is running it takes care of echoing what should be echoed, etc. –  John S Gruber Aug 3 '12 at 20:00
    
I have the same symptoms when I stop Zope (with CTRL+C) when it's running in the foreground and I'm in an ipdb debugging session. –  Mark van Lent Aug 3 '12 at 20:33
    
@MarkvanLent I think I've got that problem too –  Niels Bom Aug 6 '12 at 8:09
    
@JohnSGruber I've added the output of stty --all to my question. Thanks in advance! –  Niels Bom Aug 6 '12 at 8:14

2 Answers 2

up vote 15 down vote accepted

When running a shell or most programs in a shell anything you type is echo'd back to the user's terminal by the kernel's tty subsystem. There's other special handling, too, for erase characters, Ctrl+R, Ctrl+Z, and so on.

Certain programs, (editor's in particular) that run from a command line don't need or want this. For this reason they signal the kernel with an IOCTL call against the tty (terminal) device that they don't want this behaviour. They don't want special characters to do special things, either. Instead they ask the kernel for a "raw" mode. In particular, editor's like vim turn off various "echo settings". All this applies to real tty terminals on a computer's serial lines, or the virtual terminals at Alt+Ctrl+F1, or the really virtual terminals you get when you run something like gnome-terminal under a GUI.

Such programs are supposed to reset any modes they change on the virtual tty they are using before they quit, either by entering a quit editor command or by taking a signal (from Control+C) for example.

If they fail to do this properly the tty is left in the funny state you have discovered. Since programs can fail to reset the terminal, the reset command was written to allow the user to recover.

I assume the interrupt is messing with the python software you are running. I'd guess that that program isn't getting a chance to reset the terminal, or is simply failing to do so.

In the vim case, when I run your example I get the same behaviour you describe. I also see a message "Vim: Warning: Input is not from a terminal" (It goes away when you reset). This is because vim isn't started normally from the shell. Instead the 'grep' and 'xargs' commands have been using the standard input, normally occupied by the tty, for purposes of passing the file names from grep tto xargs.

In your posted output from stty -a we can see "-echo", also confirming that this is the problem. If you were to kill vim in such a way that it couldn't handle the signal gracefully you would probably see the same problem.

The problem is described elsewhere at http://stackoverflow.com/questions/3852616/xargs-with-command-that-open-editor-leaves-shell-in-weird-state.

A solution for the vim case is avoid xargs and use instead:

 vim $(grep foo * -l)

Here the list of files is constructed by the shell, as it had been by xargs, but the shell is calling vim, which is directly connected to the tty. There is warning message sent to the error output file, and vim sets and resets the tty settings correctly.

More references here, and another interesting one here. Another interesting solution is given in an answer to http://stackoverflow.com/questions/8228831/why-does-locate-filename-xargs-vim-cause-strange-terminal-behaviour.

share|improve this answer
    
Thanks for the thorough explanation. The complete reason why this does not work looks like a pretty deep rabbithole (tty, ioctl, etc) so I can't say I understand completely, but it's not voodoo anymore, so thanks again! –  Niels Bom Aug 7 '12 at 15:46
    
To be complete I can execute grep foo * -l | vim - without problems. So I think the problem is not with grep and xargs, but just with xargs. Would you agree? –  Niels Bom Aug 7 '12 at 15:55
1  
It's not a problem with grep or xargs. It's a problem with the fact that stdin is no longer set to the tty. This fails as well `true | vi /tmp/afile1. One of the references mentions that vim sets stdin to stdout (still the tty) because stdin has been set to /dev/null in these situtations. When it does that vim could remember and reset the echo and other settings but doesn't. I think this is a problem with vim. –  John S Gruber Aug 7 '12 at 19:11
    
This was very helpful as I have run into this. It felt random, but I bet it was always when I was trying to do something with vi that didn't exit cleanly or used a pipe. –  Michael Mathews Oct 7 at 3:49

I'd start a new user on the system (I mean make a new clean user and login there), and see if the problem is there. If it's not - then it's either Your terminal or Your X11 settings.

share|improve this answer
    
I've added a new user and tested this with the grep foo * -l | xargs vim command. The problem still exists. I don't exactly understand how my X11 settings could influence how my terminal reacts btw. Could you elaborate on that? Thanks! –  Niels Bom Aug 6 '12 at 8:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.