Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently downloaded Ubuntu 12.04 from the Ubuntu website. I checked the MD5 hash and it matched, so i burned the ISO to a disk. the burn succeeded. I put the disk into my other computer, booted into the installer, and installed the computer. I used the guided partition map, downloaded updates and all of that. the installer reports that the installation has succeeded, so i restart the computer. the BIOS says "Loading OS..." like normal, and adds dots as it tries to load the OS. that is where it stays, forever. Any help? System specs: Intel Core i5 processor (3.1 GHz) 8 GB ram HDD: Seagate Barracuda (250 GB) Motherboard: Gigabyte GA-Z68MX-UD2H-B3

share|improve this question
    
did you take it off the boot from disk on the bios and put it back to the HDD? –  Azarius Jenkins Aug 3 '12 at 5:08
    
yes. i tapped F12 to go to the boot drive menu and selected the HDD i installed it to. –  DJ_Dash Aug 3 '12 at 11:06

1 Answer 1

If I were you I would first check again the boot priorities in the BIOS. Please ensure that your hard disk is set as "first boot device" or "second boot device" if you put your CD/DVD/BD drive as first boot device. If you have more than one hard disk drive connected to the motherboard, don't forget to configure the "Hard Disk Boot Priority" in your BIOS so that the one containing GRUB is the first one in the list.

If there is no problem with boot priorities, you should try to switch the mode of your SATA controller between AHCI and IDE (I suppose that you are not trying to set up any RAID). With some motherboards (rare), using AHCI may be a problem when using Ubuntu. If it works properly with AHCI, keep this mode because it provides enhanced performances, but if it doesn't, switch to IDE mode (normally more compatible). Don't forget that your motherboard has two different SATA controllers, so you have to configure the one handling the SATA port where your hard disk drive is connected. Look at "PCH SATA Control Mode" and/or "GSATA3 Ctrl Mode" options in "Integrated Peripherals" section of your BIOS. Don't hesitate to test AHCI mode if the controller is already set up in IDE mode. If your hard disk drive is connected to the GSATA3 controller from Marvell, you may also try to connect it on a port handled by the Intel PCH controller.

If Ubuntu still does not boot properly, check that "EFI" boot is disabled. Change "EFI CD/DVD Boot Option" to "Disabled". As a last resort, you can try to set "EFI CD/DVD Boot Option" to "EFI" and reinstall Ubuntu completely.

I hope that the advices above will help you to fix your boot problem.

share|improve this answer
    
OK. Sorry for not replying sooner, my computer has since been having networking problems (fixed). I set the SATA controll modes to IDE, and said not to use EFI. That worked, but GRUB didn't show... it just booted into Ubuntu. then, because my setup had worked before, i went back and allowed AHCI. that worked. i then re-enabled EFI, and it worked! so... I JUST DON'T KNOW WHAT WENT WRONG. Thanks for your help though :) –  DJ_Dash Aug 7 '12 at 3:31
    
The problem kinda fixed itself. i followed Golboth's advice, and it worked. then i set it to my previous configuration with AHCI and EFI enabled, and it booted. It worked well, but booted slowly, so not needing EFI, i turned it off. This caused the computer to boot faster, and prevented the hangup at drive detection my MO/BO had. –  DJ_Dash Aug 7 '12 at 3:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.