Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have just installed Matlab R2011a on Ubuntu 12.04 using a standalone licence. The installation appears to have worked properly, and I have run the following to get rid of an error that everyone (including myself) seemed to be having:

sudo ln -s /lib/x86_64-linux-gnu/libc-2.13.so /lib64/libc.so.6

This got rid of the error, but I still have a problem launching Matlab. Each time I launch it (by typing "matlab" in terminal), the Mathworks software activation window pops up. I provide the path to the licence file, it appears to activate successfully (no errors), but then Matlab doesn't launch. If I try to run it again, the same thing happens.

Does anyone know what might be going wrong? My last install was 10.04, and I had absolutely no problems running 2011a.

share|improve this question

5 Answers 5

I think the licence should be updated. I fixed the problem by requesting a new licence from Mathworks and activating MATLAB with that licence file. They provided the same installation key for my computer's host id, but the 'licence.lic' file is updated. I think reinstallation is not necessary, activation with an updated licence just solves the problem.

share|improve this answer

Is it possible that launching MATLAB in that way runs the activation tool instead of MATLAB?

Try running /usr/local/MATLAB/R2011a/bin/matlab (change the path according to the location on your system) in the terminal to see if that runs MATLAB. If not, perhaps you can still get some error messages from there that might be useful for your question.

share|improve this answer

Old thread I know, but I just had this same problem. The problem for me at least, was that it is recommended installing matlab with root priviledges and as such when it came to activation the default user to be granted a licens became root. In this way I could only start matlab when logged in as root. Problem is easily fixed by running the activation again outside of root.

share|improve this answer

I asked Matlab tech-support how this can be fixed, and they said this issue can occur if you have a previous MATLAB trial license file present on your system.

To fix this delete all files in the following two folders:

$MATLAB/licenses/ (where $MATLAB is the directory where you installed MATLAB. The default is /usr/local/matlab/R2015a/licenses/ )

~/.matlab/R2015a_licenses/

cd ~/.matlab/R2015a_licenses/
rm ./license.lic

Once you have deleted all files within these folders, try launching MATLAB again. Launch it as your regular username, not as sudo or root. You will be prompted to activate once more. Complete the process one last time. Take note on the screen in the activation where it asks you for your Linux username. This should be detected automatically, and you should not change it.

Once the activation has completed, try launching MATLAB again.

Edit: Even if you get an error saying "no such file or directory" on entering the first command, you should enter the rm command.

share|improve this answer

Way too old thread but viewed 4523 times and active 16 days ago so still relevant I guess. Here is how you solve it. In my case the folder "~/.matlab/R2015a_licenses/" did not exist. though "~/.matlab" did. So I created R2015a_licenses. Now the problem is this folder was accessible only to root. So the activation application could not write the required file. So change the permission of this folder using "sudo chmod 777 R2015a_licenses". Now run matlab normally(no sudo). It should take you to the activation client. otherwise run the activation client manually(no sudo), it is called "activate_matlab.sh" in the bin folder. follow the steps and let it detect the user-name and do not change it. when it exits without error you are done with the licence part. Now there could be another problem that your matlab freezes just after the opening window and doesn't go any further. Take a look at this. "Go to the ".matlab/" directory in the users home directory. Rename the directory named after the version of MATLAB you are using to have _old at the end. If there is a folder with "_licenses" in the name, DO NOT rename that folder" kind of worked. By kind of I mean matlab complained that it cant write preferences in "~/.matlab". So I changed the permission for that folder by "chmod" and then it worked.

If you are still reading your problem is pretty bad. Good luck with it. Mathworks has clearly done a very bad job with matlab ubuntu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.