Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello I was running Ubuntu 10.04 on a desktop Dell Optiplex GX620 with onboard graphics Intel 82945g (945G), and even then I had to use xrandr to add mode 1280x1024 and edit the files in /etc/gdm, but it worked.

Support for Ubuntu version 10.04 is at an end and I was always getting reminders of it, so I downloaded ubuntu-12.04-desktop-i386.iso burnt the cd and did a clean install of ubuntu 12.04 not a distribution update, now maximum resolution is only 1024x768. I have updated the kernel now to version 3.5.0-10; however, there is no gdm folder in /etc, there is no xorg.conf file in /etc/X11 folder, and when I run xrandr I get the following:

jo@jo-Lin:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768       61.0* 
   800x600        61.0  
   848x480         0.0  
   640x480        60.0   

When I run cvt I get this result:

jo@jo-Lin:~$ cvt 1280 1024
# 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync  

Then I tried xrandr again several times:

jo@jo-Lin:~$ xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr: Failed to get size of gamma for output default
jo@jo-Lin:~$ xrandr --addmode default 1280x1024_60.00
xrandr: Failed to get size of gamma for output default
jo@jo-Lin:~$ xrandr --output default --mode 1280x1024_60.00
xrandr: Failed to get size of gamma for output default
xrandr: screen cannot be larger than 1024x768 (desired size 1280x1024)
jo@jo-Lin:~$  
share|improve this question
    
We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro Aug 12 '12 at 19:18
    
If you could edit in your video card that would really help, thanks! –  Jorge Castro Aug 12 '12 at 19:18
    
As I have said in the past A clean install of Ubuntu 12.04 has no gdm folder in /etc or xorg.conf file in /etc/X11, I have now updated the kernel to 3.5.0-10 it is installed on a desktop Dell GX620 running on board graphics Intel 82945G (945G) using xrandr creating the mode 1280x1024 and adding it and when I try to apply the new mode 1280x1024 in monitors this is the result GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._gnome_2drr_2derror_2dquark.Code3‌​‌​: required virtual size does not fit available size: requested=(1280, 1024), minimum=(640, 480), maximum=(1024, 768) –  Jose Esteves Aug 15 '12 at 7:57
add comment

3 Answers

Referring directly to your question, No. I am running 12.04 on a desktop right now.

The problem lies within your graphics drivers. First, consult your manual or computer specifications to find out whether your graphics card or graphics adapter is ATI(or AMD), nVidia, or Intel.Search for Terminal in the launcher. Then, type exactly and press enter:

sudo apt-get update

The next command will be run when you are again given a prompt. It will depend on what type of graphics card you have. If it is Intel, run:

sudo apt-get install mesa-utils

For nVidia:

sudo apt-get install nvidia-current

For ATI or AMD Vision:

sudo apt-get install flgrx

Let the command finish and then reboot.

You can install these packages using these links: mesa-utilsInstall mesa-utils nvidia-currentInstall nvidia-current flgrxInstall flgrx

share|improve this answer
    
Thank you for your reply. –  Jose Esteves Aug 5 '12 at 8:48
    
Thank you for your reply. I have applied what you recommended, to no avail, this desktop is still a laptop, therein lies the problem, until Ubuntu 12.04 can configure the desktop as a desktop there will always be a problem. –  Jose Esteves Aug 5 '12 at 8:59
    
Has anyone had this problem installing Ubuntu 12.04 on a desktop Dell GX620 running on board graphics Intel 82945G (945G),after install the system is a laptop not desktop? –  Jose Esteves Aug 5 '12 at 10:51
    
@JoseEsteves What do you mean by "This desktop is still a laptop"? –  hexafraction Aug 5 '12 at 23:40
    
When Ubuntu 12.04 installed, it sees the hardware as a laptop, all the features, drivers are for a laptop, the screen is a laptop screen, it installs synaptic touch pad mouse. –  Jose Esteves Aug 6 '12 at 5:19
show 7 more comments

The solution for me was the following; The hardware Dell Optiplex GX620 desktop onboard graphics Intel 82945G (945G), Dell – E177FPc LCD monitor native mode 1280x1024 60Hz. I was running Ubuntu 10.10 and even then had to use xrandr to create and apply the 1280x1024 mode and edit /etc/gdm/Init/Default. I downloaded Ubuntu-12.04-desktop-i386.iso burnt the CD, did a clean install, the graphics were fixed at 1024x768, did all the suggested updates updated the kernel to version 3.5.0-10 to no avail. Read all the suggestions and recommendations in Ask Ubuntu, no change and when I opened Display in System settings it told me the monitor was a Laptop therein is the problem, and as we all know version 12.04 has no gdm folder in /etc, and no xorg.conf file but that is irrelevant as you will see. What I did then was unplug the LAN cable booted up with the Ubuntu 10.10 CD and did a clean install used xrandr to create and apply the 1280x1024 mode and edit /etc/gdm/Init/Default, now everything was working resolution was 1280x1024, LAN cable still unplugged. I then booted up with the Ubuntu 12.04 CD and proceed to do an installation, at the point where it detects that you have other operating systems and previous version of Ubuntu loaded and prompts you to select what you would like to do, I selected the option to Upgrade Ubuntu 10.10, it warns you that it will replace the system files but it will leave the users home folder in place, the installation was successful. When it rebooted and I logged in, it told me it could not apply 1280x1024 resolution CRTC310 in monitors.xml, I then used xrandr to create and apply the 1280x1024 resolution mode and created the .xprofile file in the home folder with the settings used to configure xrandr and rebooted. All working in 1280x1024 mode there is now no gdm folder and still no xorg.conf file, when I go to System Settings, Displays it says Unknown not Laptop, I have plugged in the LAN cable and have installed some updates, it seems satisfactory, I will now run more updates and see what happens.

share|improve this answer
    
well I have installed 389MB of updates and updated to kernel 3.2.0-29 and every thing is working will try to install printer Cannon LBP-2900, I know this one does not get installed automatically. –  Jose Esteves Aug 17 '12 at 15:45
add comment

I had the very same problem, I was using a I-INC monitor that has 1 VGA & HDMI port. I was hooked to my GX620 via VGA cable with a "VGA to DVI convertor". In xrandr it was not detected as DVI, but as VGA instead. So I then put a "HDMI to DVI convertor" on a HDMI cable. Rebooted into a perfect HD resolution.

I had this problem with: ubuntu, linux mint, crunchbang linux, kali linux

The cable switch fixed the issue no problem on all distros.

Anyway...hope this helps those who might have the right convertors and cables lying around.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.