Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a fresh install of ubuntu 12.04 on my Dell Studio XPS (Specs at end of post) with nvidia-current installed as the proprietary drivers and I'm mainly using Gnome Classic but this issue does happen in Untiy too.

According to the workspace switcher in the corner I have 4 workspaces in a 2x2 format, when I click on another workspace it only switches between 2. Selecting workspace 3 on the launcher switches to 1 and 4 switches to 2. I have the compiz cube enabled and when rotating workspaces it is just a plane with a dekstop on each face rather than the cube.

If I go into the compiz settings and have a look at the number of workspaces it only shows 1 and if I increase them to 4 the workspace switcher changes to a 4x1 arrangement and selecting any of the other 3 not just changes to that workspace but without a desktop environment or any windows (including conky). If it hit CTRL+ALT+T for terminal it then jumps back to workspace 1 and opens a terminal.

I have been using my laptop with another monitor configured in twinview but I have also tried disabling this and using one monitor and the issue still occurs.

In want to configure it to have 4 workspaces which display properly in the compiz cube and it would be nice to have this working across both monitors.

[It would be wonderful to have 4 workspaces for each monitor and a separate cube and switcher for each one giving 8 total but I think that's just greedy :p]

Laptop spec

i7-2630QM
12GB RAM
NVIDIA gefore 555M (3D display so optimus is disabled ignores the intel HD3000)
17" Screen 1920x1080
Second monitor acer p223w 1680x1050
share|improve this question
add comment

2 Answers

up vote 2 down vote accepted
+50

Note that the switcher icon in the launcher will always show 2x2, regardless of your actual workspace layout.

The Compiz Cube is designed to work only with horizontal one-dimensional workspace layouts, not the default 2x2 Ubuntu Unity layout; changing to a 1x4 (1 vertical, 4 horizontal) workspace layout should fix it.

To make that work:

  • Open CCSM, go to General, and set the workspace layout to 1x4:

    enter image description here

  • Now disable Desktop Wall and enable the Desktop Cube and Rotate Cube plugins.

  • The default cube transition speed can be so fast that it looks like a plane. To adjust, you can tweak the Additional Settings in the Rotate Cube plugin
  • After enabling all this, reboot!

Here's a Youtube video showing the cube fully functional with 4 workspaces on one monitor. The applications are Firefox, Synaptic, Terminal and Software Center, one on each workspace.

share|improve this answer
    
I'm not using unity so the 'unity --reset' line was not needed but changing from a 2x2 to a 1x4 has done it. Can you please update your answer to reflect that. Then I will award you the bounty. –  Jacob Tomlinson Aug 13 '12 at 7:16
add comment

Install Ubuntu Tweak and use it to change the number of workspaces.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.