Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a DELL L501X computer supporting Optimus; my Nvidia chip is connected to the hdmi port. The driver is Nvidia-current; Bumblebee is installed and working. My PC resolution is set to 1366x768.

I managed to set up an external monitor simply by removing the edid line in the xorg.conf.nvidia file and starting programs with DISPLAY=:8 optirun program.

Via optirun nvidia-settings -c :8 I checked that the external screen (a tv monitor) is detected with its native resolution, which is 1920x1080. So far so good.

The problem now is that the program, e.g. Firefox, fills only the middle and upper left half of the screen. The rest remains black. Changing the resolution down to 1280 etc. the screen is filled quite better.

So what is the problem, what can I do?

share|improve this question
    
Is your tv monitor Full HD? If not, maybe you have to change down the resolution to 1280 × 720 –  user81068 Aug 3 '12 at 14:50
    
No, it's a 1080p monitor, so it should work fine. –  user81072 Aug 3 '12 at 14:56
add comment

1 Answer

I found something important out: I can start for example glxspheres with the option -fs (Full-Screen mode): DISPLAY=:8 optirun glxspheres -fs

I then get the expected behavior, glxspheres fills out the whole display. Without it, it's only partially filled.

I think, the problem is other than I originally supposed when asking the question. So I opened another question of how to get full screen with programs on the external monitor.

UPDATE: I solved all my problems thanks to these instrucions.

share|improve this answer
    
Welcome to Ask Ubuntu! This seems like it is, at least in part, an answer to the question, but it's worded as though you're asking a separate, related question. To make this clearer for people searching for help (so they know this post might help them), and to decrease the likelihood that this post will be considered not-an-answer and deleted, I recommend rewording this, and also removing anything that is actually a question (rather than a proposed solution) and posting it as a new question. –  Eliah Kagan Aug 5 '12 at 18:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.