Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

[This question has been updated as I now have the same problem with Firefox in addition to flash plugin]

The update manager (on Ubuntu 12.04, 64bit) shows an 'important security update' for flashplugin-installer:i386, firefox, and firefox-globalmenu. The update is unticked, and cannot be selected, and therefore cannot be updated (I can update other packages without problems). Actually the flashplugin-installer package does not appear to be installed on my computer (judging from the Software Centre). I can't remember how I installed flash, probably directly from the Adobe website. The updater asks me if I want to do a partial upgrade.

When running sudo apt-get update && sudo apt-get upgrade from terminal, I get the following:

The following packages have been kept back: firefox firefox-globalmenu flashplugin-installer:i386

share|improve this question
1  
Update through Terminal using sudo apt-get update && sudo apt-get upgrade and post your results. –  atenz Aug 2 '12 at 7:29
    
Have you tried upgrading from the terminal? Perhaps that gives you some more information about what might be wrong. Try sudo apt-get update && sudo apt-get upgrade, see if that gives you any more information. Important security updates are usually... important security updates, so if I were you I'd try to get it running. The version in the Software Centre is currently the same as on the Adobe website, so you shouldn't lose any functionality. –  Tomas Aug 2 '12 at 7:32
    
Please include the output of dpkg --list | grep -i flash. Thanks. –  izx Aug 2 '12 at 7:55
    
You could try to force-install the update: sudo apt-get install flashplugin-installer:i386. Don't get confused about "install" here as the app is already installed: If there is a newer version available, apt-get should plug that -- if not, it should do nothing. This way I quite often do "partial updates" (e.g. if an apt-get upgrade would include some package I want to skip temporarily). –  Izzy Aug 2 '12 at 10:56
    
thanks. I tried sudo apt-get install flashplugin-installer:i386 but I get: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies. flashplugin-installer:i386 : Depends: update-notifier-common:i386 (>= 0.119ubuntu2) but it is not installable E: Unable to correct problems, you have held broken packages. –  geoffrey Aug 2 '12 at 13:09

1 Answer 1

up vote 2 down vote accepted

When running apt-get upgrade, apt-get will not upgrade packages that requires new and/or different dependencies in the newer versions and they will be kept back.

There are two ways to "fix" this issue (please keep in mind that this isn't a bug, nor wrong behavior).

sudo apt-get install firefox firefox-globalmenu flashplugin-installer:i386

The previous command will upgrade the packages that you selected, in this case they are firefox firefox-globalmenu flashplugin-installer:i386. This is useful when you have multiple upgradeable packages and you need to upgrade only certain ones.

You can also upgrade using the following command:

sudo apt-get dist-upgrade

This is the same as sudo apt-get upgrade, with one difference being that it will install packages that requires new or different dependencies. And the difference between this and the previous command is that it will upgrade all your upgradeable packages.

EDIT:
Ok I just noticed that you said you have Ubuntu x64 and not 32, so you don't have to install the flashplugin-installer:i386 package as this is the 32bit version. Instead you can install flashplugin-installer, which will download the 64bit version.

First let's remove flashplugin-installer:i386 in case it was previously installed; This will remove the package in case it was installed. If it wasn't installed, then it will print this message:

Package flashplugin-installer:i386 is not installed, so not removed

sudo apt-get remove flashplugin-installer:i386

This step is optional, it will remove all installed and unused packages (Which are usually dependencies for previously installed then removed packages, like in this case). Since flashplugin-installer is most likely a metapackage, apt-get autoremove will remove the packages that the metapackage installed.

sudo apt-get autoremove

If the previous commands worked without any problem, try installing the 64bit version and see if your problem persists.

sudo apt-get install flashing-installer
share|improve this answer
    
Thanks, the second command worked for firefox, but not for flash. I get: The following packages have unmet dependencies. flashplugin-installer:i386 : Depends: update-notifier-common:i386 (>= 0.119ubuntu2) but it is not installable E: Unable to correct problems, you have held broken packages. –  geoffrey Sep 3 '12 at 8:19
    
Can you post the output of apt-cache policy update-notifier-common –  Dan Sep 3 '12 at 8:32
    
~$ apt-cache policy update-notifier-common update-notifier-common: Installed: 0.119ubuntu8.5 Candidate: 0.119ubuntu8.5 Version table: *** 0.119ubuntu8.5 0 500 archive.ubuntu.com/ubuntu precise-updates/main amd64 Packages 100 /var/lib/dpkg/status 0.119ubuntu8.1 0 500 archive.ubuntu.com/ubuntu precise/main amd64 Packages –  geoffrey Sep 3 '12 at 8:39
    
@geoffrey I edit the answer for you, hopefully this would help. –  Dan Sep 3 '12 at 11:44
    
BRILLIANT!! thanks! –  geoffrey Sep 3 '12 at 15:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.