Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to prevent updating of a specific package?
Keep the Ubuntu package version I'm using now
Exclude packages from apt-get upgrade

As of today (8/5/12), I tried both suggestions, and it does not seem to work. I have even tried re-starting my computer, and it doesn't seem to work.

I originally asked a question about how to un-install Rhythmbox... In that question, I also asked how do I turn off updates for Rhythmbox... That never got answered.

When I updated from Ubuntu 11.10 to Ubuntu 12.04, you guy's replaced Banshee with Rhythmbox... Well, I like Banshee better, so when I uninstalled it, next time Update Manager opens, it gives me a bunch of "updates" for Rhythmbox... which includes re-installing it... how do I stop this?

Thanks!

share|improve this question

marked as duplicate by jokerdino, Eliah Kagan, Jorge Castro, hbdgaf, Thomas W. Sep 2 '12 at 17:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

up vote 2 down vote accepted

Have you ever tried this steps?

In short:

sudo apt-mark hold <package>

or

echo <package> hold | sudo dpkg --set-selections

Answered by Zoke.

share|improve this answer
1  
Found out how, because of your answer. For anyone trying to learn how to do this, the Terminal command is sudo apt-mark hold rhythmbox –  pgrytdal Sep 1 '12 at 5:38

you are getting updates because configuration files are still in system. You should also remove Rhythmbox Configuration files. For that type in terminal

sudo dpkg -P Rhythmbox 

or

sudo dpkg --purge Rhythmbox

It removes your Package with configuration files perfectly.

share|improve this answer
3  
Just an FYI, when you are typing the commands, try to make sure the S in "sudo" is not capitalized... for us "copy and paster's" it tells us the command is invalid. If you put lower case s, it comes out correctly –  pgrytdal Aug 4 '12 at 6:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.