Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a beginner and I need some help with chroot. My system files are in /dev/sdc1. My swap is /dev/sdc2. My home partition is /dev/sdc3. I booted up the live ubuntu cd. I went to a command line. I guess, I need to mount /dev/sdc1 where my systems files are at. I tried sudo mount /dev/sdc1 /mnt and I got a message. "More filesystems detected. This should not happen. use -t to explicitly specify the file system type." I am not sure what this means. What should I do to mount /dev/sdc1?

I am trying to update grub so Ubuntu 12.04 will boot up. I believe the kernel is missing and that is why grub can't find it.

I used this link at https://help.ubuntu.com/community/Grub2/Installing#ChRoot

Any help would be great!

share|improve this question
    
Please indicate your Boot-Info URL. –  LovinBuntu Aug 2 '12 at 13:29

1 Answer 1

What does sudo fdisk -l /dev/sdc tell you?

If you used the default ext4 filesystem, you can try adding -t ext4 to the mount command (or equivalently for other FS types). However, the message suggests the filesystem or partition may be corrupt so you may need to run e.g. sudo fsck /dev/sdc1 to check it.

share|improve this answer
    
I was able to do it. I added -t ext4 and did the chroot and then updated grub and everyting worked! I use your suggestion -t ext4 for the mount command. It worked! I was able to boot into ubuntu 12.04 on sdc1. –  user80170 Aug 3 '12 at 3:59
    
Thanks for your help! –  user80170 Aug 3 '12 at 4:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.