Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I encountered an audio bug and reported it on Launchpad. There I was asked to reinstall PulseAudio.

That sounded dangerous, so I tried it on a VirtualBox virtual machine I had lying around. (this VM had no sound problems at all). And indeed, after I did a naive sudo apt-get remove pulseaudio -> reboot -> sudo apt-get install pulseaudio, the VM has no sound any more.

Strangely, everything looks OK. There is nothing muted (I unmuted every single playback chanel in alsamixer just in case). The driver for the sound card is recognized and loaded, aplay plays sound files without producing an error, and when I installed and opened PulseAudio Volume Meter, playing a sound resulted in the volume indicator changing with the sound. Only there is nothing coming out of the loudspeakers. This isn't a hardware problem either, because the sound in the host system is functioning.

I tried to configure PulseAudio as described on this page of the Ubuntu wiki, but had no success.

I am afraid to try the reinstall on my real system until I know how to do it without causing a problem. Did I miss a configuration step somewhere? Should I have reinstalled in some other way?

Both guest and host systems are Ubuntu 10.10 64 bit.

share|improve this question

4 Answers 4

Please amend your question to include the most current information from pactl stat in a Terminal and from the instructions at https://wiki.ubuntu.com/Audio/AlsaInfo. As an aside, I've contacted Fabio (the person who asked you to reinstall pulse) with clarifications to his triaging process. Thanks for your patience.

share|improve this answer
    
I solved the problem on the virtual box. Thank you for talking to Fabio, he said I don't have to reinstall on the main system, and I am happy about that. Is posting the information you requested also relevant to the initial bug, or only to the missing sound in the virtual machine? –  rumtscho Dec 13 '10 at 20:21
    
Yes, more information would still be useful, because your symptom is still arguably a bug. –  Daniel T Chen Dec 13 '10 at 22:40

Try to delete ~/.pulse/ in your home directory where there may rest some erroneous per-user settings. Don't worry it will immediately be rewritten with default settings when the PA daemon restarts.

To both, check if pulseaudio is running at all, and to start it manually if not type

pulseaudio

in a terminal. You will get an error if PulseAudio is already there.

For your bug you may want to check if settings in your /ect/pulse/daemon.conf are o.k., especially look for the entry:

flat-volumes = no

If this entry is set to yes (by default) PA will always try to output at maximum level. For detail see the PulseAudio Daemon manpage

share|improve this answer
    
Thank you for both ideas. It turns out that the problem described here was a minor VirtualBox problem. The initial bug persists, flat-volumes is set to no. But it was a good idea to check this config file, I didn't even know it existed. –  rumtscho Dec 13 '10 at 20:15

Go here : http://ubuntuforums.org/showthread.php?t=789578

Do Part A only. That should fix the problem in no time.

share|improve this answer
    
Sadly, this did not help. The packages listed in the guide apwere already installed on the system, and the sound card was already the default device in the PA volume control. So I just toggled it and restarted the VM, but the problem is still there. –  rumtscho Dec 12 '10 at 17:51
up vote 1 down vote accepted

Thank you all for the ideas.

It must have been a problem in the communication between host and Virtual Box. In the virtual machine settings, I set the sound mode from "Pulse Audio" to "Alsa" and I got sound. Then I toggled it back to Pulse Audio - and the VM still had sound.

Sometimes the answer is so easy I want to chew on something---

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.