Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to clean my PC and re-connect every cable again and in restarting it I noticed that the resolution had changed.

I then tried to return to my favorite resolution (9:16) again and I found that it had disappeared.

For your information my VGA card is built in.

I hope you can discover some kind of solution for my problem.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I'd suggest that you wiggle that monitor cable where it enters the monitor and where it is connected to the computer. Also look at the connector pins. If that fails you might try borrowing another from someone else.

There are contacts in the cable that connect the monitor to the video of your computer that communicate digitally EDID information. That information tells the operating system what constraints the monitor has on how fast it can refresh horizontally and vertically, how fast bit data can be clocked to it, and so on. It also suggests a good resolution it can handle well. It is sent in several blocks.

If a pin has been bent in a connector, or a wire has busted that information may not make it and the video drivers will only do very conservative resolutions.

You may find additional information in /var/log/Xorg.0.log looking for the string "EDID".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.