Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i want to use group-quota on my Ubuntu 12.04 LTS Server.

I've start with the following steps:

$ apt-get install quota

Edit /etc/fstab

proc /proc proc defaults 0 0
none /dev/pts devpts gid=5,mode=620 0 0
# /dev/hda1 during Installation (RescueSystem)
UUID=9f906035-68d3-4066-9d58-2b070298e175 none swap sw 0 0
# /dev/hda2 during Installation (RescueSystem)
UUID=467ed71a-2c16-4b17-9a25-2b2962cf2431 /boot ext3 defaults 0 0
# /dev/hda3 during Installation (RescueSystem)
UUID=1f06497c-cd88-6f4d-a10b-8d30b7646adb / ext4 defaults,grpquota 0 0

Reboot my server.

$ quotacheck -avg
quotacheck: Cannot remount filesystem mounted on / read-only so counted values might not be right.
Please stop all programs writing to filesystem or use -m flag to force checking.

So I try

$ quotacheck -avgm
quotacheck: Scanning /dev/disk/by-uuid/1f06497c-cd88-6f4d-a10b-8d30b7646adb [/] done
quotacheck: Old user file name could not been determined. Usage will not be    substracted.
quotacheck: Cannot stat old group quota file //aquota.group: No such file or directory.    Usage will not be substracted.
quotacheck: Checked 29572 directories and 309976 files
quotacheck: Old file not found.

Restart quota service

$ /etc/init.d/quota restart

And now i stuck here

$ repquota / 
repquota: Not all specified mountpoints are using quota.

Where is my mistake?

Thanks

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Running command with paramter "g" solved my problem:

$ repquota -g / 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.