Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install Ubuntu to an external hard drive (WD My Book Essential 1.5TB). The live CD loaded fine, and I choose custom install. I made 2 primary partitions for Root(/) and Boot(/boot) and a logical partition for the swap space. I'm pretty sure I installed GRUB into the external drive. I then booted into windows 7 and configured the rest of the space left on the drive as an NTFS partition to later backup my Windows 7.

However, when I tried to boot Ubuntu from the external drive I got a black screen with green lines going down. In the green lines were (what looked like) percentage signs. I assume this is fairly rare because its never happened to me before. My computer wouldn't do anything from there, and I had to force shut-down. This happened twice, and then I went back to Windows. The NTFS partition still works fine, so I doubt its the drive.

Does anyone know what I can do to fix this or what mistakes I may have made during installation? Any help would be appreciated. Thanks

Edit: I got it so that the screwed up screen is gone but now it's just a blank black screen and no boot. Also, I tried using the GRUB menu, but it doesn't seem to want to come up no matter what I do or what keys I press. Could it be a problem with the location GRUB is installed to?

share|improve this question

1 Answer 1

I don't know about the percentage signs pops up in your screen, but I had a graphic issue when I tried to install Ubuntu 12.04 on Dell Inspiron 1501 from USB-thumb drive. As soon as I booted in Ubuntu12.04, I got green, yellow, and red lines going down.

I solved it by using the nomodeset kernel boot option.

Since you have installed Ubuntu on your external drive you might try fixing your problem as follows:

  1. Boot to your external drive.
  2. Hold down Shift to get to the GRUB menu.
  3. Press e when GNU GRUB pops up.
  4. Delete quiet splash and type nomodeset in its plac.

Press Ctrl+X and see if Ubuntu boots normally without any graphic issue.

The above is a temporary fix. It won't carry over, the next time you boot. To make it permanent, so it works every time you boot:

  1. In the Terminal (Ctrl+Alt+T), run gksu gedit /etc/default/grub. This opens GRUB's main configuration file in a graphical text editor.
  2. In the editor, find the line that starts with GRUB_CMDLINE_LINUX_DEFAULT.
  3. On that line, delete quiet splash and add nomodeset.
  4. Press Ctrl+S to save the file, then quit the text editor.
  5. Back in the Terminal, run:

    sudo update-grub
    

Hope it fix your problem. Your problem could be partitioning,but since I don't dual boot with windows anymore I can't help that way.

Reference: http://gparted-forum.surf4.info/viewtopic.php?id=14192

share|improve this answer
    
Is there any reason you recommend removing the quiet and splash options, rather than just adding the nomodeset option (so the options line is quiet splash nomodeset)? –  Eliah Kagan Aug 2 '12 at 17:19
1  
The reason why I recommend removing quiet splash from kernel line is because user can see what's going on on the screen. It makes easier to troubleshoot boot error. It could be not pretty though. @EliahKagan –  linuxk Aug 4 '12 at 3:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.