Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While attempting to mount and sdcard from /dev/sda/

mount /dev/sda /media

I get an error

VFS: Can't find ext4 filesystem mount: you must specify the filesystem type

any ideas?

share|improve this question
Are you sure the sd card is at sda? That would usually only be the case if you have no other hard disk drives... – jmetz Aug 1 '12 at 19:19
what system are you on? Normally with unity ubuntu should mount the sdcard automatically. The error messages on the other hand gives a hint of what to do: You have to specify the file system - this should be vfat. – Thomas Aug 1 '12 at 19:23
additionally, you generally wouldn't mount anything on /media directly - it would generally be something like /media/sdcard instead. But ubuntu should automatically set that up as Thomas said. – ImaginaryRobots Aug 1 '12 at 20:01
I've answered, but if this is not a Ubuntu problem, it may be more appropriate on U&L. – Alex Chamberlain Aug 5 '12 at 21:14

Firstly use fdisk to check the disk type

fdisk -l

Use the information from there as the fs type parameter to mount,

mount -t FSTYPE /dev/sdX DIR

where FSTYPE is the file system type reported by fdisk, and DIR is the mount point, ie where you want to mount the sd card too.

Additional options to mount can be checked using

man mount 

or from here

As an alternative to mount you might also consider pmount which can be used by non-root users. The call to pmount is also simpler.

See here for further information on that.

share|improve this answer

The error

VFS: Can't find ext4 filesystem mount: you must specify the filesystem type

mean you must supply filesystem type, if not default (ext4)

mount -t filesystem /dev/sda1 /media

Where filesystem

ext3 for ext3
vfat for FAT32
ntfs-3g for NTFS

use man mount for complete options

share|improve this answer

I suspect you need to use

mount /dev/sda1 /mnt

instead, as that would mount the first partition. Furthermore, I doubt that your SD card is really /dev/sda.

To identify your SD card, run fdisk -l before inserting it. Run it afterwards and your SD card is the new disk. Notice that it will have 1 or more partitions, which will have names of the form /dev/sdxy, where x is a letter and y a number.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.