Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Unity is really buggy for me! I mean really buggy. Even while just typing the title of this it shut down and restarted itself. It doesn't always restart itself though.

A little while earlier, Unity just stopped hiding and was constantly overlayed on everything. Covering up back buttons and other options on the left side. I restarted it.

Before that it was having a weird compositing bug where the background was black while using it. I restarted the computer to fix that.

But the biggest issue is the constant crashing. While using it, or even for no reason it just freezes and then crashes.

Now I'm not here to complain for no reason. Because I actually really really like Unity. In fact I've tried Cinnamon and Gnome-Shell and I always come back to Unity. And that should be a testament to it that I still prefer it through all its bugs.

So I'm asking, is there any wikis or log files I can use to diagnose the problem myself. Because I've asked people online to help and everyone seems to be at a loss. Maybe I have some wrong variable set in some configuration file. Or at least find out what's going on. I just want Unity to be stable again like it was when I first installed Ubuntu.

[update] By the way I was able to find these three errors when running "compiz --replace" from the console.

WARN  2012-08-01 13:19:53 unity <unknown>:0 Unable to fetch children: No such interface `org.ayatana.bamf.view' on object at path /org/ayatana/bamf/application1339296950

(compiz:10636): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(compiz:10636): GLib-CRITICAL **: g_hash_table_remove_internal: assertion `hash_table != NULL' failed

It segfaults after this. "Segmentation fault (core dumped)" I've tried reinstalling desktop-ubuntu and unity --reset, but it still happens

share|improve this question

closed as off topic by Jorge Castro, Eric Carvalho, Alvar, hhlp, Ringtail Jan 1 '13 at 0:54

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Jorge Castro Dec 31 '12 at 18:48
add comment

1 Answer 1

Well, it really sounds like you should report a bug in launchpad. Please do.

However, Im pretty sure you can find a lot of unity log info in ~/.xsession-errors.

Try that, and report it to a bug report in launchpad - perhaps it has been reported before?

Good luck!

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.