Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I connect to Internet via a PPPOE connection that i configured manually as below:

/etc/ppp/peers/hamyar
#hamyar:
noipdefault 
defaultroute 
replacedefaultroute 
hide-password 
noauth 
persist 
plugin rp-pppoe.so eth0 
user "********" 
usepeerdns 

when I connect via "pon hamyar" everything works fine(i have ping response from any IP) except pinging to names like google.com and i cannot open it from my browser. what shall i do?

here's log information:

Connected to 00:09:44:6c:e8:1a via interface eth0 
Using interface ppp0 
Connect: ppp0 <--> eth0 
PAP authentication succeeded 
peer from calling number 00:09:44:6C:E8:1A authorized 
replacing old default route to eth0 [192.168.1.20] 
local IP address 178.173.139.142 
remote IP address 80.191.122.18 
primary DNS address 80.191.122.5 
secondary DNS address 4.2.2.1 
share|improve this question
    
what happens if do add google DNS as well: 8.8.8.8 –  miceterminator Aug 1 '12 at 18:17
    
in my wired lan nothin, and in /etc/ppp/resolv.conf would be overwrited to: nameserver 80.191.122.5 and nameserver 4.2.2.1 becauseof usepeerdns i think... –  sia Aug 1 '12 at 19:17
    
solved by setting system dns but still don't know why dsl dns did not work –  sia Aug 1 '12 at 19:33
    
It looks odd to me that the local IP and remote IP addresses are so disimilar. Can you ping 80.191.122.18 ? Would you mind describing what you did to fix the problem in an answer and then accepting it to help others with this problem in the future? –  John S Gruber Aug 1 '12 at 20:53
    
i'm new here and i don't have enough points to answer my own question but i'll do that as soon as i can –  sia Aug 1 '12 at 22:46

1 Answer 1

resolv.conf will be overwritten by network manager. You could edit your connection to set other DNSs servers than what you ISP gives you throw DHCP. For this run nm-connection-editor, choose your DSL connection, then IPv4 Settings tab, then on Additional DNS servers add Google DNS servers: 8.8.8.8, 8.8.4.4, or OpenDNS servers: 208.67.222.222, 208.67.220.220.

On command line you could test a DNS server with:

nslookup sitetotest.com DNSserverIPtotry

Notice that a ping is an ICMP package and DNS is an application protocol, so they live on a different layer of TCP/IP stack of protocols. A server/host could respond to a ping without having any service listening on a TCP or UDP port.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.