Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When right-clicking on a directory once I got an entry "open with vlc". Now with precise this entry is gone. How can I get it back?

edit: Yes I have it in the submenu "open with". But how can I get it in the top menu?

share|improve this question
1  
It is my understanding that once you have installed VLC, it is automatically added as an option in the "open with" of context menu. Try selecting Properties from the context menu, and in the Open With tab, select VLC. –  Peachy Aug 1 '12 at 15:07

2 Answers 2

up vote 1 down vote accepted

Using Ubuntu-tweak

  1. First install Ubuntu-tweak

  2. Then open it by typing "Ubuntu-tweak" on the dash

    Opening ubuntu tweak from dash

  3. After opening Ubuntu-tweak, go to the Admin tab

    Select Admin

  4. Then Go to the File type manager option

    file type manager

  5. In this section, do these:

    1. Select a catagory of media types, such Audio or Video
    2. Select a type of the file, such as mp3, mkv etc
    3. Double click the currently associated application such as Totem or something
    4. In the new opened small window, Select VLC media player and close it.

      changing default apps

  6. Then close the Ubuntu-tweak and see the changes by doing a Right-Click.

Instruction for Directory: After subsequent comment by the OP, I realized that, he wanted to enable an entry in the directory with "Open with VLC media player". (And OP done this, before I edit the answer. ;P).

To do so, Follow the steps from 1-5. In the step 5, the procedures are slightly changed. These are:

  1. Select the catagory All

  2. Select the file type Folder

  3. Double Click it to bring a new window. In this window, do these:

    1. Remove all entries except Files from there by selecting one and then pressing Remove button.
    2. After removing all except Files entries, Press Add button and Select the VLC media player from the new window and pressing Add button there. Remember to select the Files entry as default before closing this window.

      The final file type choosing window should look like this

      Files and VLC only

      Note that, in the image, Files entry is selected to be the default.

    3. Close all windows and close the Ubuntu tweak.

That's it.

If you ever wanted to revert the change, open Ubuntu-tweak and select the changed file type and Press the Reset button at the bottom-right position of Ubuntu tweak. All settings will be restored as before.

share|improve this answer
    
Going to "All" choosing "directory" and deleting all options not being "files" or "vlc" di the job, thanks. The directory is the only thing one can not change within nautilus. For all other types - I would do it without ubuntu tweak and with nautilus. –  pirad Aug 1 '12 at 16:51
    
How did you change the ubuntu logo? –  Aleksandar Aug 1 '12 at 17:24
    
@Aleksandar Oh I see, It is Edubuntu with Unity. Edubuntu has a different logo. See here in edubuntu website –  Anwar Shah Aug 1 '12 at 17:26
    
Okay.Thank you. –  Aleksandar Aug 1 '12 at 17:33
    
@ Aleksander you could see the icon files at '/usr/share/unity/6'. Backup this folder and make changes as you wish. But remember it will be reset after every update! (so save a backup of your changes too) –  Python Student Sep 16 '13 at 15:37

For Ubuntu 13.10 I just created a little script in the nautilus scripts folder and made it executable.

#!/usr/bin/env bash vlc -f file://pwd/$1

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.