Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Ubuntu 10.10 on a HP Compaq 8710p laptop.

No matter what option I pick in the power manager, when I close my laptop lid the screen turns off. I'd like the laptop to suspend instead.

Suspend, resume, hibernate, thaw all work well when initiated by other means.

If anyone could offer a solution, or at least set me on the right track so I can research it/debug it myself, would be great.

@Alan: Thanks, I marked the bug as affecting me and offered to submit any logs at the Launchpad bug entry.

@wag: I tried playing with manually setting the values under buttons / lid_ac entry, but no luck. Thanks anyway.

I have discovered something new though: the settings work when the laptop is running on battery (i.e. the chosen setting in g-p-m is honored). When I plug in, I can only get the blank screen when I close the lid. Maybe this would suggest this is a proper g-p-m bug, since the lid sensor seems to be functional?

share|improve this question
add comment

closed as off-topic by gertvdijk, Warren Hill, Mateo, Kevin Bowen, Eric Carvalho Jul 14 '13 at 0:38

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports should be submitted via Launchpad so that the developers are made aware of them. See: How do I report a bug?" – gertvdijk, Warren Hill, Mateo, Kevin Bowen, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

up vote 2 down vote accepted

Had a quick check and It appears that this bug #400097 in gnome-power-manager is affecting you. Quote from comment #14

I have exactly the same issue on HP Compaq 8710p. Then closing the lid, the screen just hangs, and it is set to suspend. Then I use a keyboard keys to make suspend it seems to work fine.

so I would mark that the bug effects you also and make a note of your progress in finding a solution so that others can find it.

Hope you have luck.

share|improve this answer
add comment

You could try changing some gnome-power-manager values in the gconf-editor, especially the 'action' and 'buttons' section:

gconf-editor /apps/gnome-power-manager
share|improve this answer
add comment

I had a similar issue with hibernate and it ended up being a polkit that was preventing it from hibernating.

The specific file was

/var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla

It would still let me select hibernate in my power options, but one option was preventing it from hibernating. The result was a black screen when I closed the lid, but never actually doing the commanded state as the bug describes and you do. There was a also a bug report for the hibernate issue which wasn't actually a bug.

SU to root, navigate to that folder and try to see if a setting is preventing you from suspending.

The two that were effecting me were these:

[Enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

because they were set to no. The problem was with the login1 setting because the upower is all you need to make the option selectable in the menu, so the login1 had slipped past me. (I was using a different file to enable hibernate). Anyways you could navigate to /var/lib/polkit-1/localauthority and type

grep -nr suspend .

And it will search the files in there for the word suspend. See if anything is disabling it.

share|improve this answer
    
This question is about an older Ubuntu 10.10 installation for which a bug was filed. Are you sure this still applies to this question here? –  gertvdijk Jul 13 '13 at 12:16
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.