Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have, like many, problems with suspending/hibernating in Ubuntu. When I resume from suspend the fans start, the HDD led glows steadily, but the screen is off. The only thing I do is hard reboot.

No solution have work for me so far. But I have found a workaround: downgrade from grub 2 to legacy grub. With legacy grub I can suspend just fine. My suspend/hibernate problems are somehow related to grub 2, but why? What is grubs role in the suspend process? Where to start digging?


UPDATE

I have now tried to disable graphical terminal in /etc/default/grub:

# Uncomment to disable graphical terminal (grub-pc only)  
GRUB_TERMINAL=console

That did not help. In /boot/grub/grub.cfg there is a function that concerns video:

function load_video {     
insmod vbe<br />
insmod vga<br />
}

I have no idea when, where or if it is called. Maybe it is not relevant at all.

share|improve this question
    
seems to me like the wrong command line parameters are being passed by grub2 as it normally plays no role in suspend/resume. Can you post /boot/grub/grub.cfg as well as your grub legacy (boot.lst) config? –  RolandiXor Dec 12 '10 at 19:29
    
I cannot post them, they are too long. What exactly am I looking for? –  hnrkg Dec 13 '10 at 8:32
add comment

2 Answers 2

Grub has no role in the suspend-to-RAM/resume-from-RAM-suspend process.

Grub has a role to play in the resume-from-hibernation process: it loads the kernel, which then finds a system image in the swap partition and resumes it.

If grub2 breaks hibernation with a video-related problem, while grub1 doesn't, it could be something to do with mode setting. Either GRUB2 itself is trying to change the video mode, or it's configured to pass some kernel command-line option for changing the video mode.

If hibernation doesn't work right out of the box, that's a bug in Ubuntu, and it would be a good idea to report it (using ubuntu-bug).

share|improve this answer
    
Thanks! That is what I thought. Hibernation seems to be working all right, actually. The problem is resuming from suspension. That is what makes this so strange. Grub should not affect suspension at all. I filed a bug on this some time ago, but it is progressing slowly. –  hnrkg Dec 13 '10 at 8:28
2  
Hm. Perhaps it's just the kernel command-line options end up being different? Or one of the grub versions is configured to set up a graphical mode via VESA, and the other isn't? –  Marius Gedminas Dec 13 '10 at 14:59
    
I will dive into it. I have noticed some possibly interesting lines in the grub2 config file. But I still do not really understand what grub does during suspension. I thought BIOS handled all the suspend-to-RAM as well as resuming from it. –  hnrkg Dec 13 '10 at 20:57
    
That's right, grub has nothing to do with suspend-to-RAM. The only explanation I can come up with is that grub boots the OS in a slightly different way, so it's in a different state before it enters suspend, and that's why you end up having problems on resume... –  Marius Gedminas Dec 14 '10 at 3:29
add comment

You might try uncommenting the GRUB_TERMINAL=console line in /etc/default/grub and see if that fixes it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.