Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After the upgrade to 12.04, it doesn't find drivers for my Radeon 2100 in the "Additional Drivers" window. I can't remember having problems with this before. Moving windows etc is very slow, and I suspect this is because of the missing driver.

Is there an easy way to install the driver for Radeon 2100 on Ubuntu 12.04?

$ lspci -nn | grep VGA
01:05.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Radeon 2100 [1002:796e]

enter image description here

share|improve this question
up vote 0 down vote accepted

ATI/AMD dropped Catalyst support for these cards in Catalyst 9-4. These cards are supported with the legacy ATI 9-3 Catalyst release, but you MUST use a kernel <= 2.6.28 and Xserver <= 1.5. For example, you can use Catalyst 9-3 if you're running Ubuntu 8.04 or Debian Lenny/5.0. Open source support is good and 3D is still improving.


You cannot use any driver other than the open source driver in 12.04 since you cannot use a lower version of the kernel just for drivers purpose. The legacy drivers supplied by AMD will also no work with this card.

share|improve this answer
According to this post the latest driver from AMD should support my card (R600 = HD2000). Or am I misunderstanding things? – Znarkus Aug 1 '12 at 20:15
That post is all wrong about its assumption, and btw R600 = Radeon HD 2900, not Radeon 2100 which is the RS740, please read the complete page from the AMD wiki and you will see that even for the R600 you can only use 12.4 or the open-source drivers and for the RS740 you can only use the open-source driver. – Bruno Pereira Aug 1 '12 at 20:36
Ok. Any guide for installing the open-source driver you'd recommend? – Znarkus Aug 2 '12 at 18:00
They are installed by default and on use already – Bruno Pereira Aug 2 '12 at 18:03
So you are saying since 12.04, GPU acceleration won't work in Ubuntu, and I will have to live with the laggy window movement etc? – Znarkus Aug 3 '12 at 9:21


The X2100 Series of Radeon cards are supported under the Legacy drivers of the Catalyst proprietary drivers and that may or may not be currently under development for Precise (not certain). Would suspect that the previous versions of the drivers might work, however not certain that the current versions of the Catalyst drivers will work for the X2100 series which may be why they are not being shown as found. The Legacy versions may not be under development for Precise as an alternative either and may not be given as an option. A developer may know differently though.

Your best bet may be to try to determine which version of the Catalyst Drivers was the last version to supply support for your card and try to install that driver manually from the source supplied by AMD. It is likely not to be as clean as a debian package from the sources though and would require reinstall every time the kernel is updated.

Another choice might be to buy a Video card, they are relatively inexpensive these days and you could get a slightly newer card that would have a driver available. Just another option though.

Good luck, hope this does help.

share|improve this answer
Is there a guide you can recommend for installing the driver? Is there a list of supported graphic cards for 12.04? If my card was supported in the last Ubuntu, what reason could there be to drop support for it? – Znarkus Aug 1 '12 at 20:06

I have the Radeon 2100 built into my Acer Aspire motherboard. I've been running Debian and since Ubuntu is based on Debian, you probably should install the firmware-linux-nonfree package. It has the firmware needed by both the Radeon 2100 and the free driver. The dmesg command shows that its looking for firmware RS690_cp.bin which is part of the package. You must have the firmware for GPU acceleration. I've tried the Catalyst drivers and they will not work. When I ran the Debian Wheezy net install, it downloaded and installed the free drivers but not the firmware. I got the message that no 3D effects were available until I got the firmware.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.