Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I posted a video to Youtube, and I think the youtube description and/or video (a short desktop recording with me speaking) pretty much sum it up.

http://youtu.be/EAnzrE1rqRs

[description on video]

I just wanted to post this to the askubuntu.com forums. This is for an up to date Ubuntu 12.04 ("Precise Pangolin") installed on a laptop. If anyone has an idea why either the software center will freeze when launching, or why the dash (or even alt-f2) can't find installed software like gnome-terminal, gedit, or firefox when I type it, I am interested to hear your comments.

[/end description]

Thank you for your time. :)

Edit: I noticed these problems around the same time so I have reason to suspect they are related. And I'll admit, the way I like to roll is with a root prompt - by using "sudo bash", entering my password, and running admin commands to do things that you need the prompt for. I dislike entering my password many times, and I do things that are appropriate for standard user privileges in another tab most of the time anyway. But Software Center freezing on me and nothing coming up on the dash when I hit the button with an Ubuntu logo on it and type a program's name is a slight inconvenience which less knowledgeable users may (either never encounter) or find it impossible to work around. I tried searching for a solution with Google for a while but didn't come up with much.

share|improve this question
add comment

2 Answers 2

I found another thread with the issue of the dash and I've also been having the same problem with software centre as well. Some solutions for these problems are discussed in detail here.

One suggestion on that link worked for me, and for that I entered in the terminal:

sudo unity --reset-icons

Good luck.

share|improve this answer
    
That forum thread doesn't contain the suggestion to run unity --reset-icons as root with sudo. Did you run it with sudo? This seems like a bad idea, for this reason, and because it's the non-root user's icon configuration that needs to be reset. –  Eliah Kagan Aug 2 '12 at 4:38
    
It work's great for me. Thank you. –  Vasiliy Nov 30 '13 at 12:28
add comment

Related? Thread 12289173 in UbuntuForums

I can temporarily fix software center with rm -r ~/.cache/software-center

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.