Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is this a specific unity configuration or a dual monitor configuration problems ?

In NVIDIA X Server Settings. Make this the primary display for the X screen, is my choice the middle display. But the launcher is on the left display.

share|improve this question
3  
This sound like a bug, consider reporting it on launchpad. But since unity is still in alpha versions, you should be not surprised it works incorrectly. If I were you I would give it more time and see whether they'll fix it. –  Rafał Cieślak Dec 12 '10 at 13:02
    
Can you specify in the question what version of ubuntu you're using? –  Jorge Castro Dec 12 '10 at 17:26
    
Ubuntu 11.04 Natty Narwhal Alpha –  Per Dec 12 '10 at 19:12
add comment

3 Answers

up vote 4 down vote accepted

Currently Unity sits itself down at 0,0. Supporting right monitor as primary is simply not implemented yet. It will be by release.

share|improve this answer
    
Good news. I have the same issue with dual monitor extended on the left of my notebook. –  vrcmr Jan 1 '11 at 10:56
2  
Ok, the release has happened. How come the launcher still doesn't understand it's supposed to be on the left screen? –  Sam May 11 '11 at 13:44
    
I have this problem in 11.10 too. –  Shane Wealti Feb 5 '12 at 16:28
add comment

As far as I can tell this has been fixed for nVidia binary driver in the Natty release.

For other graphics drivers there may be still issues, such as Bug 742544.

Screenshots of my setup:

desktop

share|improve this answer
add comment

I have found the cleanest way to set my primary monitor (the monitor launcher is displayed on) is with /etc/X11/xorg.conf

The important changes I have made are:

Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "TwinViewOrientation" "RightOf"
  • TwinViewXineramaInfoOrder
    • set's the primary monitor that Unity will display the launcher on.
  • TwinViewOrientation
    • set's the monitors place automatically without having to specify the resolution. (This is handy for me because of the different monitors I connect to (and the lack of monitor at times)).

My complete /etc/X11/xorg.conf:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL SE198WFP"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400M GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT: nvidia-auto-select, DFP: nvidia-auto-select"
    Option         "TwinViewOrientation" "RightOf"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this answer
add comment

protected by Oli Apr 29 '11 at 23:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.