Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop is MSi GE620 DX and it has Nvidia Optimus technology. Intel and Nvidia gfx cards. However Ubuntu doesn´t even regonize my Intel HD 3000 at all!

I even tried Fedora 17 on my system and it did regonize Intel HD 3000 straight away. But not in Ubuntu. Can´t set the correct resolution, or run Gnome 3 for example. The card just isn´t regonized.

I tried install mesa-utils, but no, did not help.

I can´t use software that needs 3d in ubuntu, but in fedora, everything works.

share|improve this question
    
The "culprit" here seems to be the Optimus technology. Have a look at this answer, it seems to be a similar problem, albeit on a different laptop. –  elmicha Aug 1 '12 at 9:16
    
I read just the other day that GPU switching ('nvidia optimus') doesnt work well at all on linux in general. I have heard that by using the latest 304 nvidia driver, support is improved, but i in no way recommend you use a bleeding edge driver. –  nisshh Aug 1 '12 at 10:14

1 Answer 1

I've an Akoya MD 6634 with Nvidia Optimus Technology and it works fine with Ubuntu 12.04. The Installation was a little bit tricky. First, you have to boot with optin "nomodeset"; in other cases yo may get a black screen (see: My computer boots to a black screen, what options do I have to fix it?).

After Installation has completed, there was no Gnome3 (always Fallback-mode). I installed "Bumblebee" - see here: http://bumblebee-project.org/; there is a discription for Ubuntu. After that, everything is fine; normally, Intel graphic is in use; to speed it up, i can use "optirun" and it get's much faster!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.