Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Changed my hardware from Nvidia to AMD in PC pretty much for gaming on my windows install. But now i have booted back into Ubuntu and its taking a hissy fit at the change of hardware.

I want to remove all types of drivers, X11 configs, EVERYTHING. Then start from scratch. I have been un-installing and reinstalling drivers for past couple of days with no luck of getting catalyst running successfully.

Any help would be great thanks alot.

Bill

share|improve this question
    
If no nvidia hardware is present it shouldn't be loading nvidia stuff, i did the same and never had a problem installing catalyst, now if you want to remove the nvidia drivers search for them using apt-cache search nvidia-* or use Synaptic and search for nvidia then uninstall. –  Uri Herrera Jul 31 '12 at 20:50
1  
This question is about going the other way round, the answers might help nonetheless: Uninstalling ATI's drivers and installing Nvidia's? –  Gilles Jul 31 '12 at 21:33
    
I found that last night mate thanks. Will update my question with how i did it soon. –  LinuxBill Aug 1 '12 at 10:11
add comment

1 Answer 1

up vote 1 down vote accepted

Right here goes on how I fixed this.

After uninstalling and reinstalling the drivers multiple times, it wouldn't successfully install the catalyst drivers without some form of issues.

sudo apt-get remove --purge fglrx fglrx-amdcccle

This removed all the AMD drivers or what was left from previous installs.

sudo apt-get --purge remove xserver-xorg-video-nouveau
sudo apt-get purge nvidia-current

Both of these commands then removed what I had from Nvidia drivers.

I then rebooted and instead of installing the AMD drivers from apt-get I used the additional drivers in the system menu. They installed fine and i rebooted again. And boom! They were there.

The thing was I had tried using the additional drivers option before only for it to fail. but not to bother it worked and im now using the latest drivers. I made a complete hash of this one and its not a great solution but a solution nevertheless.

Thanks Bill

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.