Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed latest version of ubuntu. I'm using a Netgear N150 Wireless USB Micro Adapter WNA1000M which keeps asking for network password over and over. I read elsewhere that I needed to install the latest driver for my chipset (RTL8188CUS) which I have and still no joy.

If I run the steps listed in this thread while connected through ethernet, the wireless will connect just fine. If I disconnect the ethernet, the wifi will even continue to work, but after a restart or two I will lose connection. If I repeat the steps listed in the aforementioned thread, it will not re-connect wifi unless I run those steps while connected to ethernet.......so strange...

share|improve this question
    
Please remember to accept/upvote the best answer(s) to your question when possible (tick/check mark on the left). This way, the question is marked as "answered" and future readers can refer to it knowing the solution works. Thank you...:) –  izx Aug 15 '12 at 3:35

2 Answers 2

Try installing the latest driver from Realtek, released on July 4, 2012:

  1. Download it from the website here:

    enter image description here

  2. Extract the zip file to your Downloads folder.

  3. Open a terminal with Ctrl-Alt-T, and type/paste the following, line by line:

    sudo apt-get install build-essential -y
    cd Downloads/rtl8712_8188_8191_8192SU_usb_linux_v2.6.6.0.20120405
    sudo ./install.sh
    
  4. That should build and install the latest driver -- may take a few minutes. Then reboot, and see if it's any better.
share|improve this answer
    
before sudo ./install.sh you may have to do chmod +x install.sh –  xhainingx Jun 20 at 18:32

I also started a thread concerning this same problem on the ubuntu forums. Here is the link. http://ubuntuforums.org/showthread.php?t=2036445 We ended up actually submitting a formal bug report to realtek. It appears that the driver they provide on their website is either incorrect or buggy for this product (N150 WNA1000M) on Precise 12.04. The windows driver along with running everything through WICD seemed to do the trick. Hope this helps anyone else using the N150 on 12.04.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.