Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Lubuntu 12.04 on my Toshiba netbook NB205: Atom CPU, 2GB ram... It runs nice except it boots really slow ~ 3 minutes. When I install bootchart + pybootchartgui to see what going on, the boot time suddenly improves amazingly - it boots up in ~ 1 minute.

The problem is if I disable bootchart (GRUB_CMDLINE_LINUX_DEFAULT="quiet splash bootchart=disable") or uninstall bootchart + pybootchartgui, my Lubuntu goes back to its slow boot of 3 minutes again.

Can anyone educate me on this? Thanks!

share|improve this question
    
It's hard to troubleshoot this; I recommend you keep bootchart enabled if it helps you boot much faster! It can't harm... –  izx Jul 31 '12 at 21:43
add comment

1 Answer

I have semi-good news to report. But first, thank you Bruno Pereira for editing my post - you can see English is not my native tongue. And thank you izx for your support.

I went to the bios setup and changed the SATA mode from AHCI to compatibility. My netbook now can boot up in ~ 30 seconds w/out any help from the bootchart. Why it is so, I do not know. And I still do not know the answer to the original question. But I am happy now.

share|improve this answer
    
Could be some weird timing issue. By enabling bootchart you add one additional process that might hide the bug. Maybe the same goes for disabling AHCI (I think that effectively changes the boot process too). –  htorque Aug 4 '12 at 6:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.