Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Alienware m11x R2 computer running Ubuntu 12.04 (64 bit) with Nvidia drivers and Bumblebee for Optimus technology.

The problem that I have is that if I play a video in full screen it lags, not really bad but enough to notice the lag and for me to get get frustrated. However, flash works fine; my problem lies with mp4, mkv, and other formats like these.

I have tried the default Ubuntu applications and others and they all have the same problems with video playback.

Everything works fine on Ubuntu except this and I don't know how I can fix this.

This is how I installed Bumblebee and Nvidia drivers:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo add-apt-repository ppa:bumblebee/stable 
sudo apt-get update sudo apt-get install bumblebee bumblebee-nvidia

If anyone could help it would be very much appreciated.

share|improve this question
How is video playback with Miro? – Goddard Jul 31 '12 at 19:22
It is exactly the same. I don't think it is a problem with the media players. I am quite sure I did not to something as I should. Do I need to install intel drivers to, if i have used the code above to install bumblebee??? – Rat2000 Aug 1 '12 at 10:17

I'm having the exact same problem, although I have a AMD HD5870 (with catalyst control panel) and a 32-bit system (Ubuntu 12.04).

I already disabled Sync to VBlank in Compiz config manager, but this did not do anything for my lag.


After re-enabling the Sync to Vblank in compiz-config and logging out and in, the video playback was great. I suggest you try the same.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.