Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed cardapio and its icon was in launcher as well in application lens in dash. When I unistalled cardapio, its icon vanished from the launcher (as it should) but the icon is still present in application lens in Dash. Is there a way to get rid of it?

share|improve this question
You should probably also file a bug towards the package you used for installation; packages should remove all traces (except maybe configuration) when uninstalled. – tucuxi Jul 31 '12 at 15:35
Did you log out and back in after the removal of cardapio. Changes to unity lenses might only happen after that. – con-f-use Jul 31 '12 at 16:43
yes, I did numerous times! Unfortunately, the cardapio icon in applications lens is persistent! – SteliosSk Aug 1 '12 at 6:53

Well, with help from this askubuntu question I carried out the suggestion of florian-diesch to

grep cardapio ~/.local/share/applications/*

and there was cardapio.desktop. I deleted it and now the cardapio icon does not show up any more among the applications in dash.

Thank you all for your willingness to help me solve my problem.

share|improve this answer
I have merged your accounts (N.B. it makes it easier to login to your original account if you use a registered login). You can click the tick button against the answer that helps you - either this one or the other answer in this thread. thanks. – fossfreedom Aug 2 '12 at 19:24
thanks.... Solved my problem... – Ashish Rajan Oct 10 '12 at 10:08

try to run in terminal

sudo rm /usr/share/applications/cardapio.desktop

this will remove it from launcher, after that:

sudo apt-get remove cardapio && sudo apt-get autoremove

share|improve this answer
why move to /opt (will stay there forever) instead of /tmp (will be removed on next boot) or directly delete? – tucuxi Jul 31 '12 at 15:37
@tucuxi i don't read that programm is removed ;), now i know and he can just remove it – geoh Jul 31 '12 at 15:37
Thank you for your immediate replies. As I said, I have uninstalled the cardapio application. Its icon is not anymore in launcher. It only shows in (installed) application lens in dash. – SteliosSk Jul 31 '12 at 15:38
@SteliosSk your'e welcome :D – geoh Jul 31 '12 at 15:39
@SteliosSk look at edited answer, may help – geoh Jul 31 '12 at 15:42

None of it worked for me.
What i did

  1. CtrlAltT to run terminal
  2. sudo -i to log in as superuser
  3. enter your password
  4. cd .local/share/applications
  5. ls -l

    See if you see <your_app>.desktop in here. If you do, then issue rm -f -r <your_app>.desktop to delete the file

share|improve this answer

I had the same issue. First I uninstalled the application, then I deleted all references from the following folder:



If not install this MENU editor:

sudo add-apt-repository ppa:caldas-lopes/ppa
sudo apt-get update
sudo apt-get install ezame

and delete unwanted icons.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.