Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am into a weird problem. I have installed VirtualBox in my Precise Pangolin in my laptop. My System contains two partitions. Lets presume that they are partition A and Partition B. Partition A contains Ubuntu.

Tried to install Windows XP as a guest operating system in my precise pangolin. But I couldnt install. Windows XP threw an error message while installing, stating that the files cannot be copied onto the harddisk. This scenario happens, when I have my Virtual Hard Disk for WindowsXP Guest inside Partion B. But when I have the Virtual Hard Disk inside my home folder in Ubuntu, It is running fine.

Could any one please help me resolve this issue?

Any help would be highly appreciated.

Regards, Hari

share|improve this question
    
Please list the settings of the Xp virtual machine. –  melvincv Jul 31 '12 at 13:25
    
Make sure both the Partitions are mounted , then try it. –  atenz Jul 31 '12 at 15:13
    
WindowsXP SP3: 256MB RAM, Processors:2, VirtualHDD present in drive d: (considering windows style drive names) –  Hariharan Jul 31 '12 at 16:56
    
@tijybba: Yes ofcourse the partitions are mounted at /media/Other –  Hariharan Jul 31 '12 at 16:57
add comment

2 Answers 2

Where is Partition B mounted? And how is VirtualBox pointed to it?

I have a similar setup as yours, except my host is 11.04 (Natty) and XP runs fine as a guest OS.

I have 2 drives, instead of 2 partitions. My 2nd drive is mounted at /mnt/shared, and the storage/disk in VB points to /mnt/shared/VirtualBox/VDI/WinXP.vdi.

share|improve this answer
    
I too have two drives. I just mentioned it as two partitions. My 2nd drive is mounted at /media/Other and the storage disk points to /media/Other/VirtualMachines/WinXP/HDD.vdi –  Hariharan Jul 31 '12 at 16:58
add comment

This is a permissions issue. You do not have the correct permissions assigned to the VM. You would want to do something like this:

sudo chown -R hariharan:hariharan /path/to/vm/folder

Replace hariharan:hariharan with the appropriate username:group, and /path/to/vm/folder with the path to the folder that contains the vm disk image and settings.

share|improve this answer
    
My user is an admin type. Meaning, that that the user account belongs to multiple groups. Which one should I use while specifying the username:group? –  Hariharan Jul 31 '12 at 16:59
    
The user account that launches the VBox GUI needs to be in the vboxusers group. If it doesn't exist, create it. After adding the account to that group, restart Ubuntu. The user:group doesn't need a specific value, just so long as the account that launches the gui has "write" permissions to the HDD for the VM. –  Tom Jul 31 '12 at 17:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.