Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was messing around with CompizConfig Settings Manager recently and I'm not really sure what I did to cause this issue, but now all new windows are opened at 0, 0. This means the title bar is positioned beneath the menu bar in the window z-order, making it very difficult to grab and move the window.

Here's a screenie that may explain it a little better:

  enter image description here

I was pretty much just experimenting in CompizConfig Settings Manager, I reversed any changes I made (to my knowledge), but I may have overlooked something. How can I fix this?

share|improve this question
    
try unity --replace in terminal or in the tty1 –  Prasad RD Jul 31 '12 at 10:44
    
@Prasad: nope, didn't work. Note: I have restarted my computer since, in hopes that it was a bug that would be fixed by a reboot. –  Andy E Jul 31 '12 at 10:45
    
sometimes, compiz plays with us a bit. when you click on a window, it'll disappear from there and appear in a new place... next time you know what to do, Right? –  Prasad RD Jul 31 '12 at 10:52
add comment

2 Answers

up vote 4 down vote accepted
  • Press Alt+ Ctrl + F1. login using credentials
  • Enter sudo stop lightdm
  • enter unity --reset
  • Reboot the system using sudo reboot now
  • If even after reboot, it is the same situation. Open a terminal.
  • Type in ccsm
  • Now check Unity Plugin. It might have got uncheck. Once checked it will fix every thing.

Next time take a back up in ccsm working profile. :)

Let us know if you need more help.

share|improve this answer
    
unity --reset fixed it, albeit all my settings were lost. It's not a major issue, though, and you're right; I should have made a backup! Thanks for your help. –  Andy E Jul 31 '12 at 11:57
add comment

I opened the CompizConfig Setting Manager and enabled Place Windows plugin.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.