Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am not able to install Apache 2.2 in Ubuntu 12.04. Here is a snippet from my console log (sorry, it is in German):

apache2 : Hängt ab von: apache2-mpm-worker (= 2.2.22-1ubuntu1) soll aber nicht installiert werden oder apache2-mpm-prefork (= 2.2.22-1ubuntu1) aber 2.2.22-1ubuntu1.1 soll installiert werden ...

That means like: apache2 depends from apa..worker, but that should not get installed OR from ap...prefork..ubuntu1, but ap...prefork..ubuntu1.1 should get installed.

I have no idea how to tackle that issue..

share|improve this question
    
How are you installing Apache? –  Mitch Jul 31 '12 at 10:50
    
Sudo apt-get install apache2 –  Martin Betz Jul 31 '12 at 11:28

2 Answers 2

I had exactly the same problem today. After different trials, I tried :

sudo apt-get purge apache2

And then again :

sudo apt-get install apache2

And it worked!

share|improve this answer
    
Thanks, but that does not work. I have not installed Apache before, hence apt-get purge return nothing to uninstall –  Martin Betz Jul 31 '12 at 14:54
    
The strange thing is that apt-get purge returned me the same answer as you ... as I did not manage to install apache2 before?! –  Juliette Jul 31 '12 at 15:17

Try running

sudo apt-get install apache2 apache2-mpm-prefork

The issue is that apt doesn't know which of the packages for apache2 you want.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.