Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu 12.04 installed. If i start playing music via built-in rhythmbox music player and switch user - music stops until i switch back :(. Is it possible to continue play music while switching to another user?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

I don't believe this is possible.

By the very nature of what you are doing "switching user" you are effectively logging out to transition from an environment with differing permissions and values of the other

share|improve this answer
2  
I agree, with Rhythmbox it is impossible. However there are music player demons with graphical clients. Using them you can accomplish that. You'd only close the graphical client. –  con-f-use Jul 31 '12 at 10:38
    
+1 Great! your answer will please to OP, we live and learn –  Stephen Myall Jul 31 '12 at 10:42
    
@con-f-use Any examples of such popular players? –  Eye of Hell Jul 31 '12 at 11:14
    
I already gave you one ;-). Music player daemon: mpd.wikia.com/wiki/Music_Player_Daemon_Wiki –  con-f-use Jul 31 '12 at 11:15
    
@StephenMyall "Switching User" is not logging out - user session remains and applications are running. AFAIK it's how i understood this Ubuntu functionality :) –  Eye of Hell Jul 31 '12 at 11:15

There is a launchpad bug concerning this issue. The suggested remedy is to change the 0 to a 1 for the "SYSTEM_START"-option in /etc/default/pulseaudio:

# Start the PulseAudio sound server in system mode.
# (enables the pulseaudio init script)
# System mode is not the recommended way to run PulseAudio as it has some
# limitations (such as no shared memory access) and could potentially allow
# users to disconnect or redirect each others audio streams. The
# recommend way to run PulseAudio is as a per-session daemon. For GNOME
# sessions you can install pulseaudio-esound-compat and GNOME will
# automatically start PulseAudio on login (if ESD is enabled in
# System->Preferences->Sound). For other sessions, you can simply start
# PulseAudio with "pulseaudio --daemonize".
# 0 = don't start, 1 = start
    PULSEAUDIO_SYSTEM_START=1

It is actuallz not a bug though but a feature. For most people this is expected behavior. They don't want to have other users sound playing over their own. Additionally it is standard confirm.

share|improve this answer

You could open a screen-session (by using the "screen"-command, the "screen"-package may be installed by default, but I'm not sure) Then, you could use something like mplayer (without a gui) from the command line. As the screen-session isn't terminated when logging out, mplayer will go on playing. This should work for every commandline-app, btw.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.