Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All of my google results on this question are about just learning to use synaptic.

I've noticed that Ubuntu's TTYtter package is quite a ways behind. TTYtter is just one file (one perl script) so even a newb like myself could update the Ubuntu repository without any complications of patching folders or .tar.gz's or the like.

So I think I can, and I'd like to, fix TTYtter to the more recent version. But how do I go about that?

share|improve this question
    
Even if you can update it, will you have done all the necessary testing to ensure it won't adversely effect other parts of the system? Just thinking out loud here, because I am not sure how much testing is done by Ubuntu people, and then, there are other repos you might add that will introduce other untested stuff too. –  Jazz Jul 31 '12 at 7:33
    
@ubnewbie2 It's just one perl script and it works with the default version of perl in Ubuntu. –  isomorphismes Aug 7 '12 at 6:15

2 Answers 2

up vote 6 down vote accepted

Initially do Read this Packaging/ SourceBuilds/ GettingStarted guide

First Create a Launchpad account

Then proceed to ttytter Packaging branch , then Select the Version of Ubuntu you want to Contribute to .

Contact the “Ubuntu branches” team for Uploading your version to ttytter Packaging branch.

Create your New source package recipe - Precise for Example

NOTE : I am assuming they would allow you , otherwise as con-f-use in the above answer mentioned , create your own PPA , then Upload your package to PPA.


other Useful Links

How do I create a PPA?

How do I create a PPA for a working program?

Complete Ubuntu Packaging Wiki Guide

share|improve this answer
    
Thank you tjjybba! –  isomorphismes Aug 6 '12 at 21:56

That is true with almost all applications in the Ubuntu repositories: They lag behind in their versions. The reason is that Canonical usually checks the packages for security and compatibility with Ubuntu. Also someone has to build the .deb package and upload it to the repository. That adds an extra step and slows things down but increases the quality and feel of Ubuntu.

That being said, you can't update the main repository. All you can do is create your own ppa on launchpad and hope people use it. Lauchpad has good introductory guides on how to do that. You could also get in touch with Canonical and propose your new build.

If you want to "update" TTYtter only locally on your system, you're free to do so but the next update in the main repositories might override your changes with yet another outdated version (which might break your configuration). To prevent that you should put updating on hold sudo aptitude hold ttytter (more info).

share|improve this answer
    
The "hold" should not be necessary if one sticks to the build rules and integrates the version info properly. Unless specifically told so (configuration-wise or via command line), a newer package should not be replaced by an older one. –  Izzy Jul 31 '12 at 9:11
    
In my last paragraph, I was talking locally, meaning manually replacing the files not using a package/ppa. –  con-f-use Jul 31 '12 at 9:36
    
Oh -- OK, I thought you refered to CheckInstall -- which by the way would be another approach. –  Izzy Jul 31 '12 at 12:18
1  
Thanks for the perspective, con-f-use. –  isomorphismes Aug 6 '12 at 21:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.