Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed targetcli from ubuntu repository and when I start targetcli as root, it starts and display following info:

Welcome to the targetcli shell:

 Copyright (c) 2011 by RisingTide Systems LLC.

Visit us at http://www.risingtidesystems.com.

Can't load fabric module qla2xxx.
Using iscsi fabric module.
Can't load fabric module ib_srpt.
Using tcm_fc fabric module.
Using loopback fabric module.
/> 

I've tried modprobe qla2xxx and it doesn't solve the problem.
ib_srpt is not even present in my system, only ib_srp could be found and loading it also didn't solve the problem.

I don't really know what could I do with that.
It's not related to bug: https://bugs.launchpad.net/ubuntu/+source/targetcli/+bug/1000490
Any help is greatly appreciated.

share|improve this question
add comment

1 Answer

Looking at the docs here:

http://www.linux-iscsi.org/wiki/QLogic

It appears you might need to be running with kernel 3.5 for the qla2xxx driver to be in the kernel, Precise Pangolin (12.04 LTS) is using 3.2

I have need to do this very same thing in the near future so I will endeavour to post back once I have the Qlogic hardware and have tried to make it work.

Further to this, I think that ib_srpt / ib_srp are referring to infiniband module/s so might not be a concern unless you were hoping to get LIO working using IB?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.