Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have webex installed on ubuntu 12.04 with wine as per the instructions at this link.

I'm able to open .arf files but the video is not showing up. This is the output i get when i open the application using terminal

wine: Call from 0x7b839cf2 to unimplemented function msvcp90.dll.??0?$basic_stringstream@GU?$char_traits@G@std@@V?$allocator@G@2@@std@@QAE@H@Z, aborting

EDIT : i'm trying to play an .arf file - the file works fine on windows but on my setup in ubuntu it is not working.

share|improve this question

closed as off-topic by Braiam, Eric Carvalho, minerz029, Radu Rădeanu, BuZZ-dEE Jan 21 at 7:38

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Eric Carvalho, minerz029, Radu Rădeanu, BuZZ-dEE
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Is using another player like VLC an alternative? –  Uri Herrera Jul 31 '12 at 6:17
    
doesn't look like it ... tried googling a little bit. –  Arvind Sridharan Jul 31 '12 at 6:26
    
by the way I tried installing VLC player on wine. That is working fine. –  Arvind Sridharan Jul 31 '12 at 6:35
    
Have you installed Webex player in Ubuntu? –  Mitch Jul 31 '12 at 7:42
    
VLC is available natively, no need for it to use wine. –  Uri Herrera Jul 31 '12 at 7:42

4 Answers 4

I'ld say rather than going with wine..

To play .arf files, convert them to mp4 format using the nbr2mp4 converter

  1. Download nbr2mp4 tar file from this repo.

    http://uk-dev.webex.com/support/downloads.html

  2. After you download, create a directory for the installation(I'm doing it in ~/arf

    in this example) , now , extract the tar file into this folder.

  3. Move to this folder.

     cd ~/arf/nbr2_mp4
    
  4. Now set executable permissions to nbr2mp4.sh file.

     chmod +x ./nbr2mp4.sh
    
  5. Now install the convertor by typing this command.

     ./nbr2mp4.sh
    
  6. Type the directory where you want to install the software.

    Or rather, you may hit enter to install it in the current directory.

  7. That's it, you can convert the arf files of webex to mp4 using this command.

     ./nbr2mp4 path/file-name.arf path-to-output-folder FPS
    

    Ex : ./nbr2mp4 ~/Downloads/research-talk.arf ./ 5

    A file called research-talk.mp4 will be created in the current directory.

The value of FPS can range from 3-10. The quality of the video is directly proportional to FPS.

Source : http://rodrigoguarischi.com/how-to-play-arf-file-on-ubuntu-12-04-linux/

share|improve this answer
    
The uk-dev.webex.com path required a login that I did not know. I think I have found the same file at webex.co.uk/support/downloads.html though. Thank you for the instructions. –  TafT Jul 16 at 11:11
    
Glad that helped! :) –  user151065 Jul 16 at 12:08
  1. Install WINE
  2. Download the MSI installer from the webex web-site http://www.webex.com/play-webex-recording.html
  3. Right click on it and install using WINE
  4. Run the player from the terminal wine "/home/username/.wine/drive_c/Program Files (x86)/WebEx/WebEx/500/nrplay.exe"
share|improve this answer

Install winetricks and run:

winetricks vcrun2008

Source: http://wine.1045685.n5.nabble.com/Bug-29392-New-i-cant-run-game-www-jugger-ru-will-be-very-preciate-if-you-can-help-out-td5089008.html

share|improve this answer
    
@Eliah Kagan - tried this out, still getting the same problem. this installed visual c++ on wine. –  Arvind Sridharan Aug 5 '12 at 6:00

The tool does not like any whitespace, neither in the directory path where it is residing nor the MP4 directory. The directory path and filename of the file to be converted must not contain any whitespace either.

So no whitespace anywhere -)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.