Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Only ‘sdb’ shows up when installing 12.04 on a new Dell inspiron 14z

I am new to Linux and trying to install Ubuntu 12.04 on a new HP Pavilion DV6TQE Ivy Bridge and being presented with the below screen which I believe is incorrect. My disk is set up as a basic disk (not dynamic) and I tried with a single C:\ partition and by creating a second partition in windows with no luck. Any ideas?

enter image description here

UPDATE: I think I know what the problem is but I don't know how to fix it yet.. My hard drive has a 32gb mSSD cache which is listed as dev/sdb. for some reason this is causing the installation trouble.

share|improve this question
1  
According to the selection menu at the bottom "Device for boot loader inst..." you are set to install grub onto the usb. It could also be looking in the USB /dev/sdb try selecting /dev/sda in the drop down menu. Does that show your existing partitions? –  TrailRider Jul 30 '12 at 23:46
    
/dev/sdb is the only option available. I am also installing from a dvd. should I be installing from a usb? –  Zaffiro Jul 30 '12 at 23:59
1  
dvd is fine but I'm confused as to why it's only showing sdb that is a secondary or external drive, which is why I assumed that you were using a usb, there have been some problems with usb installs installing grub in the usb instead of the main(sda) drive. try checking the disk for errors, boot into the liveDVD and press f6 then select English as the lang. then in the menu that is showing select Check Disk for Errors it will take a few minutes. If it throws any errors then you will need to download and burn a new one. This looks like it could be a bad disk problem –  TrailRider Jul 31 '12 at 0:06
    
The Check Disk for Defects came up with no errors. I am going to download the .iso again and will post my results. Thanks for your help! –  Zaffiro Jul 31 '12 at 0:18
1  
This is just a thought, if it is possible it should solve your problem, but I'm not sure it can be done. If you boot into your BIOS is there a option to disable or shut off the mSSD Cache? if so you can try shutting it off and then installing Ubuntu. I don't know if it will be supported in Ubuntu but you can turn it back on and see once you get Ubuntu installed. One other issue that might be an issue, some HP's already have 4 partitions so one has to be deleted to allow for install. You would have to check this with Windows disk management tool and see if you have 4 partitions –  TrailRider Aug 4 '12 at 5:03
show 2 more comments

marked as duplicate by RolandiXor, Eliah Kagan, andrewsomething, Stephen Myall, Tom Brossman Oct 11 '12 at 22:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4 Answers

The installer does not shows Any HDD because Your HP BIOS prevents the HDD. You have to disable this option by going into Bios Setttings and Harddisk configuration. After that You will able to see your HDD in Ubuntu Installer.

share|improve this answer
add comment

Your machine happens to have Intel Rapid Storage for RAID. If you don't know what RAID is and don't want to set it you can boot without RAID support using these instructions:

  • At boot press F6
  • Select language
  • Press F6 again and select nodmraid option
  • Continue to install
share|improve this answer
add comment

This can be a symptom of computers with Intel Smart Response Technology / Intel Rapid Storage Technology. Basically, Intel does fancy stuff (including the solid-state-drive cache) to make the disk drive faster and more reliable. It's related to RAID ... the same file may be stored in multiple places etc.

Intel has posted a PDF saying that DMRAID (the usual linux program to deal with RAID) is old and neglected, and incapable of understanding Intel's newest flavor of RAID. The other linux RAID program is mdadm (aka "MDRAID"), and supposedly works perfectly with ISRT / IRST and is supported by Intel.

Therefore, it seems to me that the most logical solution is the one suggested by oldfred here: Open ubuntu in liveCD or live-usb mode, open a terminal and type

sudo apt-get install mdadm

After that finishes (strangely, it might install an email service in the process), immediately run the livecd's installer. With any luck it will work perfectly.

When I encountered this same problem on my Dell Inspiron 14z, this procedure fixed the problem. [One other thing was, before I did the procedure above, I turned off acceleration in the Intel Rapid Storage Technology program within Windows 7.

I don't think that step was necessary though.]

share|improve this answer
    
mdadm is currently not well integrated in ubuntu to work with intel rapid storage properly. –  Dima Oct 11 '12 at 16:27
add comment

I am not trying to dual boot but here is the answer I found. From terminal issue this command:

    sudo apt-get remove dmraid

Now re-attempt the installation. This then allowed the partition table to display properly. Found the answer here: "No root file system is defined" error during installation

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.